summaryrefslogtreecommitdiff
path: root/package/openswan
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-03-05 09:22:17 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-05 23:32:17 +0100
commitecdcd55eb5a39815ea3b4737bae37c41d89cef36 (patch)
tree95ace881108d1b00bc9063ce1310bbb5e7401561 /package/openswan
parent61d3b3a1736a775f17477dab48e87a59f52776fc (diff)
openswan: do not use -fPIE for static builds
-fPIE produces shared objects, and shared objects need "/lib/ld.so" which won't be present on a statically built target. So, building openswan with -static -fPIE is invalid and will fail with an error like this one: /br/output/host/opt/ext-toolchain/bin/../lib/gcc/mipsel-ctng-linux-uclibc/4.8.2/../../../../mipsel-ctng-linux-uclibc/bin/ld: /br/output/host/usr/mipsel-buildroot-linux-uclibc/sysroot/usr/lib/libgmp.a(lt2-add.o): relocation R_MIPS_HI16 against `__gnu_local_gp' can not be used when making a shared object; recompile with -fPIC Fixes: http://autobuild.buildroot.net/results/68b/68b2211cc7acfbdfed8d4b161cbdaf1429315017/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openswan')
-rw-r--r--package/openswan/openswan.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/openswan/openswan.mk b/package/openswan/openswan.mk
index ba36f7cb1..863d1f4f9 100644
--- a/package/openswan/openswan.mk
+++ b/package/openswan/openswan.mk
@@ -11,8 +11,9 @@ OPENSWAN_LICENSE_FILES = COPYING LICENSE
OPENSWAN_DEPENDENCIES = host-bison host-flex gmp iproute2
OPENSWAN_MAKE_OPTS = ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" \
- USERCOMPILE="$(TARGET_CFLAGS) -fPIE" INC_USRLOCAL=/usr \
- USE_KLIPS=false USE_MAST=false USE_NM=false
+ USERCOMPILE="$(TARGET_CFLAGS) $(if $(BR2_STATIC_LIBS),,-fPIE)" \
+ USERLINK="$(TARGET_LDFLAGS) $(if $(BR2_STATIC_LIBS),,-fPIE)" \
+ INC_USRLOCAL=/usr USE_KLIPS=false USE_MAST=false USE_NM=false
ifeq ($(BR2_PACKAGE_LIBCURL),y)
OPENSWAN_DEPENDENCIES += libcurl