summaryrefslogtreecommitdiff
path: root/package/openvmtools
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2017-02-03 15:29:58 -0500
committerPeter Korsgaard <peter@korsgaard.com>2017-02-04 17:20:15 +0100
commitc225bd9762903b4c39524446c77f8bedcaa66bf5 (patch)
treec15c30bd2c8a79260fe514155a056e779fd68352 /package/openvmtools
parent648fef3edf2b4cd243a463a41f324c1db99eb56b (diff)
openvmtools: bump version to 5a9033ddfa95786d867e4d02bbb9a29bac8fb64f
Technically this is 10.1.0, however the initial release left out a config directory causing autoconfig to fail. See this post: https://github.com/vmware/open-vm-tools/issues/115#issuecomment-269963907 As such, I specified the hash to fix the release: https://github.com/vmware/open-vm-tools/commit/5a9033ddfa95786d867e4d02bbb9a29bac8fb64f Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/openvmtools')
-rw-r--r--package/openvmtools/openvmtools.hash2
-rw-r--r--package/openvmtools/openvmtools.mk10
2 files changed, 3 insertions, 9 deletions
diff --git a/package/openvmtools/openvmtools.hash b/package/openvmtools/openvmtools.hash
index ae2837785..bf344e506 100644
--- a/package/openvmtools/openvmtools.hash
+++ b/package/openvmtools/openvmtools.hash
@@ -1,2 +1,2 @@
# locally computed
-sha256 6b415f6093a15ffce10d3c4b69aa7ff106bdc0efd88e18a70a59d6941d4d2379 openvmtools-stable-9.10.2.tar.gz
+sha256 ff384ab0c11e19db0fd6ddab60e8ae48a4591b141fb3a8e8f1d4e1a489dd293f openvmtools-5a9033ddfa95786d867e4d02bbb9a29bac8fb64f.tar.gz
diff --git a/package/openvmtools/openvmtools.mk b/package/openvmtools/openvmtools.mk
index 40a7dac09..d3eda5c0b 100644
--- a/package/openvmtools/openvmtools.mk
+++ b/package/openvmtools/openvmtools.mk
@@ -4,11 +4,12 @@
#
################################################################################
-OPENVMTOOLS_VERSION = stable-9.10.2
+OPENVMTOOLS_VERSION = 5a9033ddfa95786d867e4d02bbb9a29bac8fb64f
OPENVMTOOLS_SITE = $(call github,vmware,open-vm-tools,$(OPENVMTOOLS_VERSION))
OPENVMTOOLS_SUBDIR = open-vm-tools
OPENVMTOOLS_LICENSE = LGPLv2.1
OPENVMTOOLS_LICENSE_FILES = $(OPENVMTOOLS_SUBDIR)/COPYING
+
# Autoreconf needed or config/missing will run configure again at buildtime
OPENVMTOOLS_AUTORECONF = YES
OPENVMTOOLS_CONF_OPTS = --with-dnet \
@@ -45,13 +46,6 @@ else
OPENVMTOOLS_CONF_OPTS += --without-pam
endif
-# configure needs execution permission
-define OPENVMTOOLS_PRE_CONFIGURE_CHMOD
- chmod 0755 $(@D)/$(OPENVMTOOLS_SUBDIR)/configure
-endef
-
-OPENVMTOOLS_PRE_CONFIGURE_HOOKS += OPENVMTOOLS_PRE_CONFIGURE_CHMOD
-
# symlink needed by lib/system/systemLinux.c (or will cry in /var/log/messages)
# defined in lib/misc/hostinfoPosix.c
# /sbin/shutdown needed for Guest OS restart/shutdown from hypervisor