summaryrefslogtreecommitdiff
path: root/package/openvpn
diff options
context:
space:
mode:
authorAndreas Wetzel <andreas.wetzel@nanotronic.ch>2015-09-23 11:39:48 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-30 13:04:33 +0200
commit58dfd45aec6de8213bb34c10506117aa88b6ca2a (patch)
treec5780273667cf43cb2d01cd506d7bdadc1523b04 /package/openvpn
parent7b0e757fb85fd88a76fb4528926914288eb2e477 (diff)
openvpn: add option for --enable-password-save
Added configuration option BR2_PACKAGE_OPENVPN_PWSAVE that adds --enable-password-save to OPENVPN_CONF_OPTS if selected. [Thomas: rewrap Config.in help text, as suggested by Vicente.] Signed-off-by: Andreas Wetzel <andreas.wetzel@nanotronic.ch> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openvpn')
-rw-r--r--package/openvpn/Config.in6
-rw-r--r--package/openvpn/openvpn.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/package/openvpn/Config.in b/package/openvpn/Config.in
index 5edb479d9..2e3712554 100644
--- a/package/openvpn/Config.in
+++ b/package/openvpn/Config.in
@@ -27,6 +27,12 @@ config BR2_PACKAGE_OPENVPN_SMALL
You loose eurephia, debugging info, help messages and more.
It saves around 100 KiB in binary file size.
+config BR2_PACKAGE_OPENVPN_PWSAVE
+ bool "Allow passwords in files"
+ help
+ Allow --askpass and --auth-user-pass passwords to be read
+ from a file.
+
choice
prompt "Crypto backend"
default BR2_PACKAGE_OPENVPN_CRYPTO_OPENSSL
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 1caa9a033..2973928a7 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -41,6 +41,12 @@ else
OPENVPN_CONF_OPTS += --disable-lzo
endif
+ifeq ($(BR2_PACKAGE_OPENVPN_PWSAVE),y)
+OPENVPN_CONF_OPTS += --enable-password-save
+else
+OPENVPN_CONF_OPTS += --disable-password-save
+endif
+
ifeq ($(BR2_PACKAGE_OPENVPN_CRYPTO_OPENSSL),y)
OPENVPN_CONF_OPTS += --with-crypto-library=openssl
OPENVPN_DEPENDENCIES += openssl