summaryrefslogtreecommitdiff
path: root/package/openvpn
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2017-01-09 16:13:42 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-24 23:24:46 +1300
commit878dc8cc9b9d774bc7821156af3cd838c435453b (patch)
tree7217f7fe82b9aa0377f30a49f8fb76e7e105c002 /package/openvpn
parentd34c0cc5800e4af4889e8631d343fcf0a894a43a (diff)
openvpn: bump version to 2.4.0
--enable-password-save option has been removed (https://github.com/OpenVPN/openvpn/commit/9ffd00e7541d83571b9eec087c6b3545ff68441f). Since it now defaults to "enabled" in the upstream package, there is no point in adding Config.in.legacy support for it: Config.in.legacy logic only kicks in when the option is enabled, but the upstream package precisely preserve the compatibility with this situation. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openvpn')
-rw-r--r--package/openvpn/Config.in6
-rw-r--r--package/openvpn/openvpn.hash2
-rw-r--r--package/openvpn/openvpn.mk8
3 files changed, 2 insertions, 14 deletions
diff --git a/package/openvpn/Config.in b/package/openvpn/Config.in
index 8ba4ea197..5fa191d97 100644
--- a/package/openvpn/Config.in
+++ b/package/openvpn/Config.in
@@ -28,10 +28,4 @@ config BR2_PACKAGE_OPENVPN_SMALL
You loose eurephia, debugging info, help messages and more.
It saves around 100 KiB in binary file size.
-config BR2_PACKAGE_OPENVPN_PWSAVE
- bool "Allow passwords in files"
- help
- Allow --askpass and --auth-user-pass passwords to be read
- from a file.
-
endif
diff --git a/package/openvpn/openvpn.hash b/package/openvpn/openvpn.hash
index a21608a4b..600c25073 100644
--- a/package/openvpn/openvpn.hash
+++ b/package/openvpn/openvpn.hash
@@ -1,2 +1,2 @@
# Locally calculated
-sha256 f3a0d0eaf8d544409f76a9f2a238a0cd3dde9e1a9c1f98ac732a8b572bcdee98 openvpn-2.3.14.tar.xz
+sha256 6f23ba49a1dbeb658f49c7ae17d9ea979de6d92c7357de3d55cd4525e1b2f87e openvpn-2.4.0.tar.xz
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 1765fb4ec..5e3df59f3 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -4,7 +4,7 @@
#
################################################################################
-OPENVPN_VERSION = 2.3.14
+OPENVPN_VERSION = 2.4.0
OPENVPN_SOURCE = openvpn-$(OPENVPN_VERSION).tar.xz
OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
OPENVPN_DEPENDENCIES = host-pkgconf openssl
@@ -42,12 +42,6 @@ else
OPENVPN_CONF_OPTS += --disable-lzo
endif
-ifeq ($(BR2_PACKAGE_OPENVPN_PWSAVE),y)
-OPENVPN_CONF_OPTS += --enable-password-save
-else
-OPENVPN_CONF_OPTS += --disable-password-save
-endif
-
define OPENVPN_INSTALL_TARGET_CMDS
$(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
$(TARGET_DIR)/usr/sbin/openvpn