summaryrefslogtreecommitdiff
path: root/package/openzwave
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2016-10-23 19:59:11 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-24 17:51:02 +0200
commitc77f7c689ffc8c5fd139e4622bd6f9d315bbc254 (patch)
treec4d8406d2339723fc50159bf055487eaf9a9f3ab /package/openzwave
parent548b0d541c8bdd890d7af5eb3094c4a606304c63 (diff)
openzwave: fix compilation of MinOZW
LIBDIR was used in cpp/examples/MinOZW/Makefile to add dynamic libraries. However, as it was unset by default, the cross-compilation could fail if the host had a library such as libnss3.so in /. To fix this issue, this patch sets LIBDIR to top_buildir if it is unset Fixes: http://autobuild.buildroot.net/results/68719fdf1320a69310bada6d3c47654dacdb5898 Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openzwave')
-rw-r--r--package/openzwave/openzwave.hash1
-rw-r--r--package/openzwave/openzwave.mk6
2 files changed, 7 insertions, 0 deletions
diff --git a/package/openzwave/openzwave.hash b/package/openzwave/openzwave.hash
index cd1231f80..d07961edb 100644
--- a/package/openzwave/openzwave.hash
+++ b/package/openzwave/openzwave.hash
@@ -1,2 +1,3 @@
# Locally computed:
sha256 abfb4c7e7728e86ba374c2e0ef7de912594eb24a8c44935457352df844530238 openzwave-V1.5.tar.gz
+sha256 98851964fd8de3dd40f00d0032b47c61c17a4cf789ad5792e14149da5ab8755e 599e2a11c6f48dde744012ec45686c08e15f3059.patch
diff --git a/package/openzwave/openzwave.mk b/package/openzwave/openzwave.mk
index 2723086b8..199d9e1bd 100644
--- a/package/openzwave/openzwave.mk
+++ b/package/openzwave/openzwave.mk
@@ -13,6 +13,12 @@ OPENZWAVE_LICENSE_FILES = license/license.txt license/lgpl.txt \
OPENZWAVE_DEPENDENCIES = host-pkgconf udev
OPENZWAVE_INSTALL_STAGING = YES
+# This patch fixes incorrect default value of LIBDIR:
+# http://autobuild.buildroot.net/results/68719fdf1320a69310bada6d3c47654dacdb5898
+# This patch is currently in dev branch and will be a part of v1.6
+OPENZWAVE_PATCH = \
+ https://github.com/OpenZWave/open-zwave/commit/599e2a11c6f48dde744012ec45686c08e15f3059.patch
+
# Set instlibdir to install libopenzwave.so* in the correct directory
# otherwise openzwave will check that /lib64 exists (on the host) to
# know if the library should be installed in $(PREFIX)/lib or $(PREFIX)/lib64.