summaryrefslogtreecommitdiff
path: root/package/parted
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-12-12 19:18:42 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-12-12 23:58:39 +0100
commit749b2589ea63cbdcf180d019441a05dcaef4ebe9 (patch)
tree1b5fe8e417d3f563a3301bd45e2ad27acd230c3c /package/parted
parent2079f07a926ec0b489ab30befe0cb2bcaebc40f6 (diff)
package/parted: add a host variant
Useful for for-build scripts to call parted, eg. to generate partition tables and such automatically. Since the primary goal is to use parted within scripts, we do not need readline, so it is forcibly disabled. Also, it does look unlikely that we need to manipulate LVM volumes, so we forcibly disable support for the device-mapper. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/parted')
-rw-r--r--package/parted/Config.in.host6
-rw-r--r--package/parted/parted.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/package/parted/Config.in.host b/package/parted/Config.in.host
new file mode 100644
index 000000000..f5d7acc2a
--- /dev/null
+++ b/package/parted/Config.in.host
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_HOST_PARTED
+ bool "host parted"
+ help
+ parted, the GNU partition resizing program
+
+ http://www.gnu.org/software/parted/
diff --git a/package/parted/parted.mk b/package/parted/parted.mk
index afb8287f1..15e37a8c6 100644
--- a/package/parted/parted.mk
+++ b/package/parted/parted.mk
@@ -26,4 +26,10 @@ else
PARTED_CONF_OPT += --disable-device-mapper
endif
+HOST_PARTED_DEPENDENCIES = host-util-linux
+HOST_PARTED_CONF_OPT += \
+ --without-readline \
+ --disable-device-mapper \
+
$(eval $(autotools-package))
+$(eval $(host-autotools-package))