summaryrefslogtreecommitdiff
path: root/package/perl
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2015-03-03 20:53:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-04 19:40:13 +0100
commit8a4c8deee9af6fa1a1e906c52d7d49a32434464c (patch)
tree77f0b9c020f2d0a018ab9c5646ed8218755b08aa /package/perl
parent4668ec8a9bbbe110ed5e08be8dca7a28b564d06d (diff)
perl: fix build caused by bison generated code
This commit makes sure the date of a C file is newer than the date of the corresponding Bison source file, so that the build process doesn't try to regenerate it. This avoids the need to have host-bison as a dependency for the perl build. Fixes: http://autobuild.buildroot.net/results/1c2/1c261b09f5a4a314d5dcbc1e5811af9c7d18658a/ Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/perl.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 0636abaf5..cd4c2867d 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -85,6 +85,7 @@ endif
define PERL_CONFIGURE_CMDS
(cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_CONF_OPTS))
$(SED) 's/UNKNOWN-/Buildroot $(BR2_VERSION_FULL) /' $(@D)/patchlevel.h
+ touch $(@D)/x2p/a2p.c # prevents regen by yacc
endef
define PERL_BUILD_CMDS