summaryrefslogtreecommitdiff
path: root/package/perl
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2015-10-04 13:28:45 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-10-04 18:22:20 +0200
commit906a01128c3537c0e255bb0c66384fbde4ac6a97 (patch)
tree9e2a37670e2069d25f68bf974840e31548e56953 /package/perl
parentd82f69cf100c51cc65c9fb27132517dd3efd554a (diff)
perl: Remove ccache handling
Now the ccache handling has moved to the toolchain wrapper, it is no longer necessary to pass TARGET_CC_NOCCACHE. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/perl.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index b9f90e48c..719270041 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -45,13 +45,12 @@ PERL_DEPENDENCIES += gdbm
endif
# We have to override LD, because an external multilib toolchain ld is not
-# wrapped to provide the required sysroot options. We also can't use ccache
-# because the configure script doesn't support it.
+# wrapped to provide the required sysroot options.
PERL_CONF_OPTS = \
--target=$(GNU_TARGET_NAME) \
--target-tools-prefix=$(TARGET_CROSS) \
--prefix=/usr \
- -Dld="$(TARGET_CC_NOCCACHE)" \
+ -Dld="$(TARGET_CC)" \
-Dccflags="$(TARGET_CFLAGS)" \
-Dldflags="$(TARGET_LDFLAGS) -lm" \
-Dmydomain="" \