summaryrefslogtreecommitdiff
path: root/package/perl
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-10-03 16:17:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-03 23:02:47 +0200
commite1a4b820fff98cd5ba9ba12c4e7605496e7793b9 (patch)
treeac506aa2a16cd689ec31c29a9ba8aede7309af6f /package/perl
parente1524980f5f13273266cdb647e3f8743475efd4d (diff)
package/perl: bump version to 5.24.0
perl-cross has a new version scheme since 1.1.0: https://github.com/arsv/perl-cross/releases perl does not contain a version-specific perldelta.pod anymore: https://rt.perl.org/Public/Bug/Display.html?id=129328#txn-1424561 Therefore PERL_CROSS_SET_POD was changed accordingly. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/perl.hash12
-rw-r--r--package/perl/perl.mk16
2 files changed, 13 insertions, 15 deletions
diff --git a/package/perl/perl.hash b/package/perl/perl.hash
index 4afbd06d6..72063d8e5 100644
--- a/package/perl/perl.hash
+++ b/package/perl/perl.hash
@@ -1,7 +1,7 @@
-# Hashes from: http://www.cpan.org/src/5.0/perl-5.22.2.tar.bz2.{md5,sha1,sha256}.txt
-md5 24ec0b41fdd1a4cce0e66811ae1f5e1b perl-5.22.2.tar.bz2
-sha1 e2f465446dcd45a7fa3da696037f9ebe73e78e55 perl-5.22.2.tar.bz2
-sha256 f2322b9b04fe0cdbca9fe755360da04892cb6483d44959457cfebc0bcddc8058 perl-5.22.2.tar.bz2
+# Hashes from: http://www.cpan.org/src/5.0/perl-5.24.0.tar.bz2.{md5,sha1,sha256}.txt
+md5 59456ae4bd4b06cb6e57cb19a3b2d349 perl-5.24.0.tar.xz
+sha1 9d5424ac2debe979d1f7255fe0c818aff0b41b4c perl-5.24.0.tar.xz
+sha256 a9a37c0860380ecd7b23aa06d61c20fc5bc6d95198029f3684c44a9d7e2952f2 perl-5.24.0.tar.xz
-# No upstream hashes for the following
-sha256 250ab6e6c034a8b7ae447fa2b453fa0b61ebb7db4d039eba60c52e44ab5899bd perl-5.22.1-cross-1.0.2.tar.gz
+# From https://github.com/arsv/perl-cross/releases/download/1.1.0/perl-cross-1.1.0.hash
+sha256 d02e1f60076307655ace2c63fe38832e6d81d6195af84a98221e1c617c6c733d perl-cross-1.1.0.tar.gz
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 29b445593..ac7d41896 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -5,23 +5,21 @@
################################################################################
# When updating the version here, also update support/scripts/scancpan
-PERL_VERSION_MAJOR = 22
-PERL_VERSION = 5.$(PERL_VERSION_MAJOR).2
+PERL_VERSION_MAJOR = 24
+PERL_VERSION = 5.$(PERL_VERSION_MAJOR).0
PERL_SITE = http://www.cpan.org/src/5.0
-PERL_SOURCE = perl-$(PERL_VERSION).tar.bz2
+PERL_SOURCE = perl-$(PERL_VERSION).tar.xz
PERL_LICENSE = Artistic or GPLv1+
PERL_LICENSE_FILES = Artistic Copying README
PERL_INSTALL_STAGING = YES
-PERL_CROSS_VERSION = 1.0.2
-PERL_CROSS_BASE_VERSION = 5.$(PERL_VERSION_MAJOR).1
+PERL_CROSS_VERSION = 1.1.0
# DO NOT refactor with the github helper (the result is not the same)
PERL_CROSS_SITE = https://github.com/arsv/perl-cross/releases/download/$(PERL_CROSS_VERSION)
-PERL_CROSS_SOURCE = perl-$(PERL_CROSS_BASE_VERSION)-cross-$(PERL_CROSS_VERSION).tar.gz
+PERL_CROSS_SOURCE = perl-cross-$(PERL_CROSS_VERSION).tar.gz
PERL_EXTRA_DOWNLOADS = $(PERL_CROSS_SITE)/$(PERL_CROSS_SOURCE)
-PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod
-PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
+PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
# We use the perlcross hack to cross-compile perl. It should
# be extracted over the perl sources, so we don't define that
@@ -34,7 +32,7 @@ endef
PERL_POST_EXTRACT_HOOKS += PERL_CROSS_EXTRACT
define PERL_CROSS_SET_POD
- $(SED) s/$(PERL_CROSS_OLD_POD)/$(PERL_CROSS_NEW_POD)/g $(@D)/Makefile
+ $(SED) s/$(PERL_CROSS_OLD_POD)/perldelta.pod/g $(@D)/Makefile
endef
PERL_POST_PATCH_HOOKS += PERL_CROSS_SET_POD