summaryrefslogtreecommitdiff
path: root/package/php-ssh2
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-05-23 15:51:35 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-31 21:32:20 +0200
commit08af64d6a5e7d6b37c954335e2b4c7e96e2e3647 (patch)
tree1d5a57ddaf93ef711d4ef280433327770927506e /package/php-ssh2
parent96ad5fa0529b03f8a2aba0c7ec0d61fe2c8f3d18 (diff)
php-ssh2: re add package, now compatible with PHP 7
Related: https://bugs.php.net/bug.php?id=71376 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/php-ssh2')
-rw-r--r--package/php-ssh2/Config.in8
-rw-r--r--package/php-ssh2/php-ssh2.hash2
-rw-r--r--package/php-ssh2/php-ssh2.mk25
3 files changed, 35 insertions, 0 deletions
diff --git a/package/php-ssh2/Config.in b/package/php-ssh2/Config.in
new file mode 100644
index 000000000..b45790074
--- /dev/null
+++ b/package/php-ssh2/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PHP_SSH2
+ bool "php-ssh2"
+ depends on BR2_PACKAGE_PHP
+ select BR2_PACKAGE_LIBSSH2
+ help
+ PHP bindings for the libssh2 library.
+
+ http://pecl.php.net/package/ssh2
diff --git a/package/php-ssh2/php-ssh2.hash b/package/php-ssh2/php-ssh2.hash
new file mode 100644
index 000000000..1e046dfcd
--- /dev/null
+++ b/package/php-ssh2/php-ssh2.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 877f2fa9a709aa2dd9567848fae7b45ecac359904296a0aedbf718e99d8568f5 php-ssh2-aa1739ac26c2177d33ab8d064021032bdc2c3a40.tar.gz
diff --git a/package/php-ssh2/php-ssh2.mk b/package/php-ssh2/php-ssh2.mk
new file mode 100644
index 000000000..cfe60708c
--- /dev/null
+++ b/package/php-ssh2/php-ssh2.mk
@@ -0,0 +1,25 @@
+################################################################################
+#
+# php-ssh2
+#
+################################################################################
+
+PHP_SSH2_VERSION = aa1739ac26c2177d33ab8d064021032bdc2c3a40
+PHP_SSH2_SITE = $(call github,php,pecl-networking-ssh2,$(PHP_SSH2_VERSION))
+PHP_SSH2_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+ --with-ssh2=$(STAGING_DIR)/usr
+# phpize does the autoconf magic
+PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
+PHP_SSH2_LICENSE = PHP
+PHP_SSH2_LICENSE_FILES = LICENSE
+
+define PHP_SSH2_PHPIZE
+ (cd $(@D); \
+ PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+ PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+ $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
+
+$(eval $(autotools-package))