summaryrefslogtreecommitdiff
path: root/package/php-ssh2
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-05-23 15:51:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-31 21:31:34 +0200
commit6f6b4dc16b07dcf901fc986b6aa22f67e4280f13 (patch)
tree6f0797c3295c5102b945512e0f9339f70b192795 /package/php-ssh2
parentdd2e328089c12685400bd124e70ff6a28cac025a (diff)
php: bump version to 7.0.6
Remove MySQL legacy extension. Remove incompatible external modules: - php-gnupg - php-memcached - php-ssh2 - php-yaml Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/php-ssh2')
-rw-r--r--package/php-ssh2/Config.in8
-rw-r--r--package/php-ssh2/php-ssh2.hash2
-rw-r--r--package/php-ssh2/php-ssh2.mk27
3 files changed, 0 insertions, 37 deletions
diff --git a/package/php-ssh2/Config.in b/package/php-ssh2/Config.in
deleted file mode 100644
index b45790074..000000000
--- a/package/php-ssh2/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_PHP_SSH2
- bool "php-ssh2"
- depends on BR2_PACKAGE_PHP
- select BR2_PACKAGE_LIBSSH2
- help
- PHP bindings for the libssh2 library.
-
- http://pecl.php.net/package/ssh2
diff --git a/package/php-ssh2/php-ssh2.hash b/package/php-ssh2/php-ssh2.hash
deleted file mode 100644
index d599662fa..000000000
--- a/package/php-ssh2/php-ssh2.hash
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally calculated
-sha256 600c82d2393acf3642f19914f06a7afea57ee05cb8c10e8a5510b32188b97f99 ssh2-0.12.tgz
diff --git a/package/php-ssh2/php-ssh2.mk b/package/php-ssh2/php-ssh2.mk
deleted file mode 100644
index ace68e01f..000000000
--- a/package/php-ssh2/php-ssh2.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-################################################################################
-#
-# php-ssh2
-#
-################################################################################
-
-PHP_SSH2_VERSION = 0.12
-PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
-# pecl.php.net returns html with db connect failed
-PHP_SSH2_SITE = http://sources.buildroot.net
-PHP_SSH2_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
- --with-ssh2=$(STAGING_DIR)/usr
-# phpize does the autoconf magic
-PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
-PHP_SSH2_LICENSE = PHP
-PHP_SSH2_LICENSE_FILES = LICENSE
-
-define PHP_SSH2_PHPIZE
- (cd $(@D); \
- PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
- PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
- $(STAGING_DIR)/usr/bin/phpize)
-endef
-
-PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
-
-$(eval $(autotools-package))