summaryrefslogtreecommitdiff
path: root/package/php
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2015-05-18 21:52:01 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-19 21:41:10 +0200
commitccbeeb8a8cf1157eaf01550d4d6b479883bbcae7 (patch)
treea41506ab1d52392bd51d50e85d86d2eab9886800 /package/php
parent2bba2edad8c55a93b34ff1d42db758b89ac376f4 (diff)
php: enable opcache extension in php.ini if selected
Add a line to load the opcache extension in php.ini, at the bottom of the "dynamic extensions" section. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index bc3794af8..6e0e216ea 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -301,6 +301,9 @@ define PHP_INSTALL_FIXUP
$(TARGET_DIR)/etc/php.ini
$(SED) 's%;date.timezone =.*%date.timezone = $(PHP_LOCALTIME)%' \
$(TARGET_DIR)/etc/php.ini
+ $(if $(BR2_PACKAGE_PHP_EXT_OPCACHE),
+ $(SED) '/;extension=php_xsl.dll/azend_extension=opcache.so' \
+ $(TARGET_DIR)/etc/php.ini)
endef
PHP_POST_INSTALL_TARGET_HOOKS += PHP_INSTALL_FIXUP