summaryrefslogtreecommitdiff
path: root/package/pinentry
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-02-27 16:38:07 +0000
committerPeter Korsgaard <peter@korsgaard.com>2015-02-28 08:10:48 +0100
commit63f5f44e6138344b31d81cf8b760ea613b00c75d (patch)
tree502429a75151283f7a29ec100fc2fbc1d245e183 /package/pinentry
parent5f91f5765ad174a801d3daefaa3e1ffa210293ea (diff)
pinentry: fix ncurses' unsafe header path
pinentry sets the NCURSES_INCLUDE variable in the Makefile to /usr/include/ncurses and that causes problems when cross-compiling because it fails with an error like this one: Making all in curses make[3]: Entering directory `/br/output/build/pinentry-0.9.0/curses' /br/output/host/usr/bin/mips64el-ctng_n64-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/ncursesw -I../pinentry -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os -Wall -Wcast-align -Wshadow -Wstrict-prototypes -Wno-pointer-sign -c pinentry-curses.c mips64el-ctng_n64-linux-gnu-gcc: ERROR: unsafe header/library path used in cross-compilation: '/usr/include/ncursesw' make[3]: *** [pinentry-curses.o] Error 1 Fixes: http://autobuild.buildroot.net/results/5b9/5b9b53a37f7cf4bab4d989f852726a0f0885605f/ [Peter: use --with-ncurses-include-dir=none instead] Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pinentry')
-rw-r--r--package/pinentry/pinentry.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pinentry/pinentry.mk b/package/pinentry/pinentry.mk
index f34cc0e10..c4d83ee80 100644
--- a/package/pinentry/pinentry.mk
+++ b/package/pinentry/pinentry.mk
@@ -21,7 +21,7 @@ endif
# pinentry-ncurses backend
ifeq ($(BR2_PACKAGE_PINENTRY_NCURSES),y)
-PINENTRY_CONF_OPTS += --enable-ncurses
+PINENTRY_CONF_OPTS += --enable-ncurses --with-ncurses-include-dir=none
PINENTRY_DEPENDENCIES += ncurses
else
PINENTRY_CONF_OPTS += --disable-ncurses