summaryrefslogtreecommitdiff
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-11-12 01:25:51 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-22 20:36:42 +0100
commit2fceab73f111a9466a7fd30df5d4162e02788504 (patch)
tree521322620da58a519d00114756c0081b0e3b1cf1 /package/pkg-autotools.mk
parentd2ae901036897bd9b4a0c3b2835a70667c076bf5 (diff)
pkg-autotools: remove redundant shell conditional
The libtool patching function checks whether patching libtool is wanted before doing the actual patching. This is redundant now, as all callers are now protected by a conditional block. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk24
1 files changed, 11 insertions, 13 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 45947b008..e240b95c1 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -44,19 +44,17 @@ endef
#
define PATCH_LIBTOOL
@$(call MESSAGE,"Patching libtool")
- $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES" ]; then \
- for i in `find $(1) -name ltmain.sh`; do \
- ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$i | \
- sed -e 's/\([0-9].[0-9]*\).*/\1/' -e 's/\"//'`; \
- if test $${ltmain_version} = '1.5'; then \
- $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
- elif test $${ltmain_version} = "2.2"; then\
- $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
- elif test $${ltmain_version} = "2.4"; then\
- $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.4.patch; \
- fi \
- done \
- fi
+ $(Q)for i in `find $(1) -name ltmain.sh`; do \
+ ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$i | \
+ sed -e 's/\([0-9].[0-9]*\).*/\1/' -e 's/\"//'`; \
+ if test $${ltmain_version} = '1.5'; then \
+ $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
+ elif test $${ltmain_version} = "2.2"; then\
+ $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
+ elif test $${ltmain_version} = "2.4"; then\
+ $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.4.patch; \
+ fi \
+ done
endef
# This function generates the ac_cv_file_<foo> value for a given