summaryrefslogtreecommitdiff
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-08-28 23:03:44 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-08-29 09:17:33 +0200
commit3e37b0fc6cbbe2245e39fedb247a381fb4e0d992 (patch)
tree6082543ea5401942cd0eb951a848cedd3c65079c /package/pkg-autotools.mk
parent49e36dcf1307b81b7f24c9d7feab71183d86c2e9 (diff)
pkg-autotools: use --disable-dependency-tracking
By default, automake does "dependency tracking", which allows the generated Makefile to contain the necessary dependencies to automatically rebuild the appropriate C files when included header files are changed. This dependency tracking is nice when doing active development on the package, but not really useful when doing a one-time build of the package. According to automake's documentation[1], disabling the dependency tracking provides a small speed-up. In some very unscientific measurements (i.e repeated only once), we have noticed a ~3.6% reduction of the total build time of a Buildroot toolchain after applying this patch. [1] http://www.gnu.org/software/automake/manual/html_node/Dependency-Tracking.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index bcc648dd6..83299cf54 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -140,6 +140,7 @@ define $(2)_CONFIGURE_CMDS
--disable-documentation \
--with-xmlto=no \
--with-fop=no \
+ --disable-dependency-tracking \
$$(DISABLE_NLS) \
$$(DISABLE_LARGEFILE) \
$$(DISABLE_IPV6) \
@@ -169,6 +170,7 @@ define $(2)_CONFIGURE_CMDS
--disable-documentation \
--with-xmlto=no \
--with-fop=no \
+ --disable-dependency-tracking \
$$(QUIET) $$($$(PKG)_CONF_OPT) \
)
endef