summaryrefslogtreecommitdiff
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-10-19 11:59:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-19 17:07:14 +0200
commit822a757456e8d5f2b68ed8fd9b242efc6327958e (patch)
treee27b8211efe88c3107868d09c5f1515aff1b051f /package/pkg-autotools.mk
parent2641edb8c49e0531af87eb00a35784785d604ec9 (diff)
infra: Move --enable/--disable-debug to package/Makefile.in
A lot of packages ignored BR2_ENABLE_DEBUG. This patch simplifies the handling of this option by adding the corresponding configure option to the global Makefile for target packages. For host packages --disable-debug is added to the global Makefile. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 3c5430f7d..80adc8bf7 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -146,6 +146,7 @@ define $(2)_CONFIGURE_CMDS
$$(DISABLE_NLS) \
$$(DISABLE_LARGEFILE) \
$$(DISABLE_IPV6) \
+ $$(ENABLE_DEBUG) \
$$(SHARED_STATIC_LIBS_OPTS) \
$$(QUIET) $$($$(PKG)_CONF_OPTS) \
)
@@ -172,6 +173,7 @@ define $(2)_CONFIGURE_CMDS
--disable-doc \
--disable-docs \
--disable-documentation \
+ --disable-debug \
--with-xmlto=no \
--with-fop=no \
--disable-dependency-tracking \