summaryrefslogtreecommitdiff
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2014-08-22 11:12:53 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-15 00:35:58 +0200
commitf8d4fe376cf65cc4e41423804869a79c2570f674 (patch)
treebec5fbde46d1edbbf936e1e6fbbb6b680c3ad699 /package/pkg-autotools.mk
parent139cb9d99932dc4b31e72aa53e6f42306d265baa (diff)
package/pkg-autotools: don't use config.site when cross-compiling
On fedora 20 64bits host, the file /usr/share/config.site contains a fix for installing libraries into /lib/lib64 on 64bits systems that redefine libdir in the generated Makefile For safety and avoid the bug #7262 [1], disable loading this file when running the configure script for the target and the host. Note: configure scripts generated with autoconf < 2.65 will source the /dev/null and print this line: "configure: loading site script /dev/null" [1]: https://bugs.busybox.net/show_bug.cgi?id=7262 Signed-off-by: Romain Naour <romain.naour@openwide.fr> Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 83299cf54..4404f15cf 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -126,6 +126,7 @@ define $(2)_CONFIGURE_CMDS
$$(TARGET_CONFIGURE_OPTS) \
$$(TARGET_CONFIGURE_ARGS) \
$$($$(PKG)_CONF_ENV) \
+ CONFIG_SITE=/dev/null \
./configure \
--target=$$(GNU_TARGET_NAME) \
--host=$$(GNU_TARGET_NAME) \
@@ -160,6 +161,7 @@ define $(2)_CONFIGURE_CMDS
CFLAGS="$$(HOST_CFLAGS)" \
LDFLAGS="$$(HOST_LDFLAGS)" \
$$($$(PKG)_CONF_ENV) \
+ CONFIG_SITE=/dev/null \
./configure \
--prefix="$$(HOST_DIR)/usr" \
--sysconfdir="$$(HOST_DIR)/etc" \