summaryrefslogtreecommitdiff
path: root/package/pkg-cmake.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:03 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:10:35 +0100
commit26aef889f1df32d5a15cd70f6b1e316ebb830cb7 (patch)
tree9baed5f64e8c19f89bd2f723353f2fa5b54b9486 /package/pkg-cmake.mk
parentac57c640c6e2d605f25d150bdede17f6f94edd76 (diff)
infra: remove unused 4th parameter to package infrastructures (pkgparentdir)
The fourth parameter to inner-generic-package is no longer used. Removing this parameters requires renaming all usages of $(5) to $(4), and updating the calls to inner-generic-package (and equivalent for the other package infrastructures). Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-cmake.mk')
-rw-r--r--package/pkg-cmake.mk13
1 files changed, 6 insertions, 7 deletions
diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 36283f07c..dbe0d97c9 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -31,8 +31,7 @@
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-cmake-package
@@ -55,7 +54,7 @@ $(2)_BUILDDIR = $$($(2)_SRCDIR)
# packages.
#
ifndef $(2)_CONFIGURE_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
# Configure package for target
define $(2)_CONFIGURE_CMDS
@@ -99,7 +98,7 @@ $(2)_DEPENDENCIES += host-cmake
# file.
#
ifndef $(2)_BUILD_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
define $(2)_BUILD_CMDS
$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_MAKE_OPT) -C $$($$(PKG)_BUILDDIR)
endef
@@ -142,7 +141,7 @@ endif
# Call the generic package infrastructure to generate the necessary
# make targets
-$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+$(call inner-generic-package,$(1),$(2),$(3),$(4))
endef
@@ -150,8 +149,8 @@ endef
# cmake-package -- the target generator macro for CMake packages
################################################################################
-cmake-package = $(call inner-cmake-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
-host-cmake-package = $(call inner-cmake-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
+cmake-package = $(call inner-cmake-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
+host-cmake-package = $(call inner-cmake-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),host)
################################################################################
# Generation of the CMake toolchain file