summaryrefslogtreecommitdiff
path: root/package/pkg-cmake.mk
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-08-21 22:45:18 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-28 20:52:52 +0200
commit474a0e113ea4448e83733838cecb9bf39e5931a5 (patch)
treecbc7d92c73a1284b76a72f136e0e00a79a313589 /package/pkg-cmake.mk
parent0b10e0cf573e732e7e723041d958f519e88524c4 (diff)
toolchainfile.cmake.in: set linker flags
The linker flags are part of the toolchain configuration, so set them for the CMake-based packages. Signed-off-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-cmake.mk')
-rw-r--r--package/pkg-cmake.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 365575177..2006b76bc 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -177,6 +177,7 @@ $(HOST_DIR)/usr/share/buildroot/toolchainfile.cmake:
-e 's:@@STAGING_SUBDIR@@:$(call qstrip,$(STAGING_SUBDIR)):' \
-e 's:@@TARGET_CFLAGS@@:$(call qstrip,$(TARGET_CFLAGS)):' \
-e 's:@@TARGET_CXXFLAGS@@:$(call qstrip,$(TARGET_CXXFLAGS)):' \
+ -e 's:@@TARGET_LDFLAGS@@:$(call qstrip,$(TARGET_LDFLAGS)):' \
-e 's:@@TARGET_CC_NOCCACHE@@:$(subst $(HOST_DIR)/,,$(call qstrip,$(TARGET_CC_NOCCACHE))):' \
-e 's:@@TARGET_CXX_NOCCACHE@@:$(subst $(HOST_DIR)/,,$(call qstrip,$(TARGET_CXX_NOCCACHE))):' \
$(TOPDIR)/support/misc/toolchainfile.cmake.in \