summaryrefslogtreecommitdiff
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-05-07 18:14:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-24 16:22:36 +0200
commit1686c58e63032cacd3cb05bc255f87b44a5f12c8 (patch)
tree300fcc85c7e0081ffec5988f9a733da21d114bd8 /package/pkg-generic.mk
parent1273636fc686cd788b6de87be75dd0726cf8676c (diff)
core/legal-info: also save extra downloads
Some packages, like perl, download extra files that end up as part of the source that Buildroot builds. Up until now, those files were not saved in the legal-info output. Add those files to the legal-info output. The unfortunate side-effect is that we will also save the secondary archive for the external blackfin toolchains; however, we already do save the binary release of some external toolchains when they do not provide actual source archives. This is inherently bad, as those are not source archives, but solving this is a bigger concern, for another series... Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Luca Ceresoli <luca@lucaceresoli.net> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Tested-by: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 2508d75cc..86747707e 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -804,10 +804,12 @@ ifeq ($$($(2)_REDISTRIBUTE),YES)
ifneq ($$($(2)_ACTUAL_SOURCE_TARBALL),$$($(2)_SOURCE))
$$(call DOWNLOAD,$$($(2)_ACTUAL_SOURCE_SITE)/$$($(2)_ACTUAL_SOURCE_TARBALL))
endif
-# Save the source tarball
- $$(Q)support/scripts/hardlink-or-copy \
- $$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL) \
- $$($(2)_REDIST_SOURCES_DIR)
+# Save the source tarball and any extra downloads, but not
+# patches, as they are handled specially afterwards.
+ $$(foreach e,$$($(2)_ACTUAL_SOURCE_TARBALL) $$(notdir $$($(2)_EXTRA_DOWNLOADS)),\
+ $$(Q)support/scripts/hardlink-or-copy \
+ $$(DL_DIR)/$$(e) \
+ $$($(2)_REDIST_SOURCES_DIR)$$(sep))
# Save patches and generate the series file
$$(Q)while read f; do \
support/scripts/hardlink-or-copy \