summaryrefslogtreecommitdiff
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2015-07-12 19:27:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-12 21:53:00 +0200
commit470cd0dcada5c2df8c84d89dba1077ad74d1e599 (patch)
tree383be28a0b2ea3f3ef91d1602f501dbf99bbad5f /package/pkg-generic.mk
parent34ee471f2a96af1f1415f2e854ddf67175615ce9 (diff)
Fix selection of bootloaders from $(BR2_EXTERNAL)
If a package is based on "generic-package", pkg-generic.mk will compute the name of the Kconfig variable to use for checking if this package has been selected by the user. Unfortunately, this mechanism does not take into account the case where a bootloader is declared in a $(BR2_EXTERNAL)/boot directory. So, even if the bootloader has been selected, it will not be added to $(TARGETS) and will not be built. This patch fixes this issue. [Arnout: use single filter line, also apply this to toolchain] Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 82376df0e..e85b4bf04 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -642,9 +642,9 @@ $$($(2)_TARGET_DIRCLEAN): PKG=$(2)
# kernel case, the bootloaders case, and the normal packages case.
ifeq ($(1),linux)
$(2)_KCONFIG_VAR = BR2_LINUX_KERNEL
-else ifneq ($$(filter boot/%,$(pkgdir)),)
+else ifneq ($$(filter boot/% $(BR2_EXTERNAL)/boot/%,$(pkgdir)),)
$(2)_KCONFIG_VAR = BR2_TARGET_$(2)
-else ifneq ($$(filter toolchain/%,$(pkgdir)),)
+else ifneq ($$(filter toolchain/% $(BR2_EXTERNAL)/toolchain/%,$(pkgdir)),)
$(2)_KCONFIG_VAR = BR2_$(2)
else
$(2)_KCONFIG_VAR = BR2_PACKAGE_$(2)