summaryrefslogtreecommitdiff
path: root/package/pkg-kconfig.mk
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2016-05-28 00:03:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-28 19:46:47 +0200
commit02302d21536b9c19cd87733f4eb1bd62065416bb (patch)
tree4a4ba676c2a867321ffc3474b92ca9d26887b000 /package/pkg-kconfig.mk
parent2ef21bc8d4e893faa81f75ef5130fa47f4dde468 (diff)
core/pkg-kconfig: pass host PKG_CONFIG_PATH env var
This is basically the same change as in 0515fe45661b6d320f8d2071df2 ("Makefile: pass host PKG_CONFIG_PATH at "make menuconfig" time"). That commit made sure to pass host PKG_CONFIG_PATH when invoking Buildroot's own menuconfig program. This change ensures that the same is true for third party menuconfig programs (i.e. Linux, uClibc and Busybox). This unbreaks "make {linux,uclibc}-menuconfig" for host platforms which rely on PKG_CONFIG_PATH to find .pc files (e.g. NixOS). (When Busybox updates to a more recent Kconfig snapshot, one that uses pkg-config to find ncurses, "make busybox-menuconfig" will also start working.) Tested on Ubuntu and NixOS: $ make qemu_arm_versatile_defconfig $ make linux-menuconfig $ make Signed-off-by: Bjørn Forsman <bjorn.forsman@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-kconfig.mk')
-rw-r--r--package/pkg-kconfig.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index 40d2f881a..b0f51789c 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -143,7 +143,8 @@ endif
# nconfig, gconfig, xconfig).
# So we simply remove our PATH and PKG_CONFIG_* variables.
$(2)_CONFIGURATOR_MAKE_ENV = \
- $$(filter-out PATH=% PKG_CONFIG=% PKG_CONFIG_SYSROOT_DIR=% PKG_CONFIG_LIBDIR=%,$$($(2)_MAKE_ENV))
+ $$(filter-out PATH=% PKG_CONFIG=% PKG_CONFIG_SYSROOT_DIR=% PKG_CONFIG_LIBDIR=%,$$($(2)_MAKE_ENV)) \
+ PKG_CONFIG_PATH="$(HOST_PKG_CONFIG_PATH)"
# Configuration editors (menuconfig, ...)
#