summaryrefslogtreecommitdiff
path: root/package/pkg-kconfig.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2015-02-03 15:21:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-14 16:34:04 +0100
commit1941386c3da9a4d5f14ab2c3c500188a0e221c08 (patch)
treea5a1627c73e4dbf91f33d7e9d3b4b0e914e1ea2c /package/pkg-kconfig.mk
parent39867f3c8cba642cb2dc98b165992a6cc2fa1cb5 (diff)
kconfig infra: make update-config/defconfig handling symmetrical
Replace a 'cp --preserve' with a 'touch --reference' so that the code for foo-update-config and foo-update-defconfig is symmetrical to ease maintainability and increase clarity. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: "Yann E. Morin" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-kconfig.mk')
-rw-r--r--package/pkg-kconfig.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index db56b7afc..f76c7a79f 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -78,8 +78,11 @@ $(1)-savedefconfig: $$($(2)_DIR)/.stamp_kconfig_fixup_done
$$($(2)_KCONFIG_OPTS) savedefconfig
# Target to copy back the configuration to the source configuration file
+# Even though we could use 'cp --preserve-timestamps' here, the separate
+# cp and 'touch --reference' is used for symmetry with $(1)-update-defconfig.
$(1)-update-config: $$($(2)_DIR)/.stamp_kconfig_fixup_done
- cp --preserve=timestamps -f $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
+ cp -f $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
+ touch --reference $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
# Note: make sure the timestamp of the stored configuration is not newer than
# the .config to avoid a useless rebuild. Note that, contrary to