summaryrefslogtreecommitdiff
path: root/package/pkg-kernel-module.mk
diff options
context:
space:
mode:
authorNoé Rubinstein <noe.rubinstein@gmail.com>2015-08-17 09:10:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-17 16:29:52 +0200
commit8df95d926e963601c727defeb4ab90ce2368da70 (patch)
tree5c5d4493b879f5f9fdb11de54ea689b0819be688 /package/pkg-kernel-module.mk
parent3ffa368342aa13bd79f0e672d9eefe26f0ab85de (diff)
pkg-kernel-module: die if kernel module support is disabled
Test the configuration of the kernel to see if loadable module support is enabled, and error out otherwise. This makes build failures of external kernel modules less confusing. [Thomas: tweak the commit log.] Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-kernel-module.mk')
-rw-r--r--package/pkg-kernel-module.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pkg-kernel-module.mk b/package/pkg-kernel-module.mk
index 5fb19be80..6fb7704e3 100644
--- a/package/pkg-kernel-module.mk
+++ b/package/pkg-kernel-module.mk
@@ -60,6 +60,10 @@ $(2)_MODULE_SUBDIRS ?= .
# includes and other support files (Booo!)
define $(2)_KERNEL_MODULES_BUILD
@$$(call MESSAGE,"Building kernel module(s)")
+ @if ! grep -Fqx 'CONFIG_MODULES=y' $(LINUX_DIR)/.config; then \
+ echo "ERROR: Kernel does not support loadable modules"; \
+ exit 1; \
+ fi
$$(foreach d,$$($(2)_MODULE_SUBDIRS), \
$$(LINUX_MAKE_ENV) $$($$(PKG)_MAKE) \
-C $$(LINUX_DIR) \