summaryrefslogtreecommitdiff
path: root/package/pkg-luarocks.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:45 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:30 +0200
commita603eb1c470eb0d265368d017640521c4a385e5e (patch)
treef6dcf80b434cd7e8b0aea54c58f7dac8b2f732fc /package/pkg-luarocks.mk
parentaaffd209fae91a733fe0becb72268f87bf4ea369 (diff)
packages: rename FOO_BUILD_OPT into FOO_BUILD_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_BUILD_OPT. Sed command used: find * -type f | xargs sed -i 's#_BUILD_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-luarocks.mk')
-rw-r--r--package/pkg-luarocks.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index 95b397c9f..f0fb73d0a 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -33,7 +33,7 @@
define inner-luarocks-package
-$(2)_BUILD_OPT ?=
+$(2)_BUILD_OPTS ?=
$(2)_SUBDIR ?= $(1)-$$(shell echo "$$($(3)_VERSION)" | sed -e "s/-[0-9]$$$$//")
$(2)_ROCKSPEC ?= $(1)-$$($(3)_VERSION).rockspec
$(2)_SOURCE ?= $(1)-$$($(3)_VERSION).src.rock
@@ -59,7 +59,7 @@ endif
ifndef $(2)_INSTALL_TARGET_CMDS
define $(2)_INSTALL_TARGET_CMDS
cd $$($(2)_SRCDIR) && \
- $$(LUAROCKS_RUN) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPT)
+ $$(LUAROCKS_RUN) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPTS)
endef
endif