summaryrefslogtreecommitdiff
path: root/package/pkg-rebar.mk
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2016-02-02 14:57:28 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-20 16:55:25 +0100
commit6be72cd8ca093c53f17d1a5b982daf2cca800b11 (patch)
treef39724b063a305ebcbe3a64a7d82966a1bd2a670 /package/pkg-rebar.mk
parentb640c257ea96cf6a81b804c902f11dbeb4ff6836 (diff)
pkg-rebar.mk: pass C++ compiler path and options
Previously only the C compiler path and options were passed to rebar. Erlang projects that used the C++ compiler would fail to build, which would for example be the case with the latest version of erlang-p1-stringprep. This fixes those errors. Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Reviewed-by: Romain Naour <romain.naour@gmail.com> [Thomas: adjust commit message to indicate an example of an Erlang package that needs the C++ compiler.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-rebar.mk')
-rw-r--r--package/pkg-rebar.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/pkg-rebar.mk b/package/pkg-rebar.mk
index c727489be..44c6d6c8d 100644
--- a/package/pkg-rebar.mk
+++ b/package/pkg-rebar.mk
@@ -158,7 +158,9 @@ ifndef $(2)_BUILD_CMDS
define $(2)_BUILD_CMDS
(cd $$(@D); \
CC="$$(TARGET_CC)" \
+ CXX="$$(TARGET_CXX)" \
CFLAGS="$$(TARGET_CFLAGS)" \
+ CXXFLAGS="$$(TARGET_CXXFLAGS)" \
LDFLAGS="$$(TARGET_LDFLAGS)" \
$$(REBAR_TARGET_DEPS_ENV) \
$$(TARGET_MAKE_ENV) \