summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2013-11-12 09:47:58 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-11-17 09:15:04 +0100
commit366f17f747197c449970480ff628b8fc5d87a71e (patch)
tree3497791f20cc5b001f0cd849e45edcbed96cf186 /package/pkg-utils.mk
parentcc4f34ddd4d9f501811b3c86262cdb05ab506460 (diff)
legal info: split license texts for host and target
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index f7400614b..86fa5da87 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -107,15 +107,15 @@ endef
legal-manifest=echo '"$(1)","$(2)","$(3)","$(4)","$(5)"' >>$(LEGAL_MANIFEST_CSV_$(6))
define legal-license-header
echo -e "$(LEGAL_INFO_SEPARATOR)\n\t$(1):" \
- "$(2)\n$(LEGAL_INFO_SEPARATOR)\n\n" >>$(LEGAL_LICENSES_TXT)
+ "$(2)\n$(LEGAL_INFO_SEPARATOR)\n\n" >>$(LEGAL_LICENSES_TXT_$(3))
endef
define legal-license-nofiles
- $(call legal-license-header,$(1),unknown license file(s))
+ $(call legal-license-header,$(1),unknown license file(s),$(2))
endef
-define legal-license-file # pkg, filename, file-fullpath
- $(call legal-license-header,$(1),$(2) file) && \
- cat $(3) >>$(LEGAL_LICENSES_TXT) && \
- echo >>$(LEGAL_LICENSES_TXT) && \
- mkdir -p $(LICENSE_FILES_DIR)/$(1)/$(dir $(2)) && \
- cp $(3) $(LICENSE_FILES_DIR)/$(1)/$(2)
+define legal-license-file # pkg, filename, file-fullpath, type
+ $(call legal-license-header,$(1),$(2) file,$(4)) && \
+ cat $(3) >>$(LEGAL_LICENSES_TXT_$(4)) && \
+ echo >>$(LEGAL_LICENSES_TXT_$(4)) && \
+ mkdir -p $(LICENSE_FILES_DIR_$(4))/$(1)/$(dir $(2)) && \
+ cp $(3) $(LICENSE_FILES_DIR_$(4))/$(1)/$(2)
endef