summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-04 19:16:46 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-04 19:16:46 +0100
commit371327f7b6a7be641ecb109bb0f42d5d9550382b (patch)
tree771e3c20faea618179ee567b5eb27df9595a065a /package/pkg-utils.mk
parent0dc7901b00a581453896a65fb08ad8261c747521 (diff)
Revert "packages infra: add function to get a Kconfig option"
This reverts commit c28a28eed1943c1efb958448a87a2e8f0baf48d6. The whole host-lzop optional dependency logic cannot work, since the configuration file will only be known after the kernel sources are extracted, if an internal kernel defconfig is used, which is quite common. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 99fefe6a4..91a198160 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -52,8 +52,6 @@ define KCONFIG_DISABLE_OPT
echo "# $(1) is not set" >> $(2)
endef
-KCONFIG_GET_OPT = $(shell sed -e 's/^$(1)=//p' $(2))
-
# Helper functions to determine the name of a package and its
# directory from its makefile directory, using the $(MAKEFILE_LIST)
# variable provided by make. This is used by the *TARGETS macros to