summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-09-29 00:08:36 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-29 08:40:32 +0200
commit57ae95be21f8e550bc387a54e8086b8abc48c612 (patch)
treefedb5f7a634485aa15891b6f1fa61047a9738369 /package/pkg-utils.mk
parent5638c6435787379406a4507ea6830975117a82a8 (diff)
pkg-utils: qstrip MESSAGE
Currently, the MESSAGE macro double-quotes the message. But a few call sites also double-quote the message, resulting in a borked call to echo, like: $(call MESSAGE,"user text") would expand to: echo "Leading text "user message" trailign text" Just use qstrip on the user message, so we get protected from either a comma in the user text (so make does not interpret it), or a semi-colon (so the shell does not interpret it.) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 89ad9e9c6..44766a062 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -67,7 +67,7 @@ INFLATE.tar = cat
suitable-extractor = $(INFLATE$(suffix $(1)))
# MESSAGE Macro -- display a message in bold type
-MESSAGE = echo "$(TERM_BOLD)>>> $($(PKG)_NAME) $($(PKG)_VERSION) $(1)$(TERM_RESET)"
+MESSAGE = echo "$(TERM_BOLD)>>> $($(PKG)_NAME) $($(PKG)_VERSION) $(call qstrip,$(1))$(TERM_RESET)"
TERM_BOLD := $(shell tput smso)
TERM_RESET := $(shell tput rmso)