summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:04 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:10:44 +0100
commit582af5884ff98f292b4f15f8379e6bb9004f5c51 (patch)
treead90a7e01036c7e13526ab258583c32945bdda94 /package/pkg-utils.mk
parent26aef889f1df32d5a15cd70f6b1e316ebb830cb7 (diff)
infra: remove unused helper function pkgparentdir
Thanks to the previous patches, no-one is using pkgparentdir anymore, so remove it. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 51dd7384b..91a198160 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -55,12 +55,9 @@ endef
# Helper functions to determine the name of a package and its
# directory from its makefile directory, using the $(MAKEFILE_LIST)
# variable provided by make. This is used by the *TARGETS macros to
-# automagically find where the package is located. Note that the
-# pkgdir macro is carefully written to handle the case of the Linux
-# package, for which the package directory is an empty string.
+# automagically find where the package is located.
pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
pkgname = $(lastword $(subst /, ,$(pkgdir)))
-pkgparentdir = $(patsubst %$(pkgname)/,%,$(pkgdir))
# Define extractors for different archive suffixes
INFLATE.bz2 = $(BZCAT)