summaryrefslogtreecommitdiff
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorClayton Shotwell <clshotwe@rockwellcollins.com>2014-07-21 08:46:31 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-23 23:36:43 +0200
commitaf629e49ad26bd2873c1e39c0f263704ed8957a1 (patch)
treef432828ff321239cf32e8aaf41235bb9c53378ba /package/pkg-utils.mk
parent2cadb26e6d4267998e6927bd5b972b2cffeb19e0 (diff)
legal-info: Add site to legal info manifest
I would like to propose adding the site to the legal-info manifest files. This gives a little more information on where the sources came from without adding much overhead. Please note that is is only for packages where the source is not local or set with OVERRIDE_SRCDIR. Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 99e1f7644..89ad9e9c6 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -105,8 +105,8 @@ define legal-warning-nosource # pkg, {local|override}
$(call legal-warning-pkg,$(1),sources not saved ($(2) packages not handled))
endef
-define legal-manifest # pkg, version, license, license-files, source, {HOST|TARGET}
- echo '"$(1)","$(2)","$(3)","$(4)","$(5)"' >>$(LEGAL_MANIFEST_CSV_$(6))
+define legal-manifest # pkg, version, license, license-files, source, url, {HOST|TARGET}
+ echo '"$(1)","$(2)","$(3)","$(4)","$(5)","$(6)"' >>$(LEGAL_MANIFEST_CSV_$(7))
endef
define legal-license-header # pkg, license-file, {HOST|TARGET}