summaryrefslogtreecommitdiff
path: root/package/pkg-virtual.mk
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2015-07-14 13:36:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-14 18:08:23 +0200
commit7a6b83a211612ff95a1f5d35b2861ad5655ac8b1 (patch)
treeaca5004d46dc09c23c27e3fe207bd09bdb472fd7 /package/pkg-virtual.mk
parentc7ca4e81163700146e39f3b9aba90225bad86b45 (diff)
skeleton: New package
Create a proper package for the skeleton. The main Makefile is modified to remove the skeleton support. The 'dirs' target, will create the $(TARGET_DIR). The file 'output/target/.root' doesn't exists anymore, as there's no Make rule to statisfy. The infrastructure are modified to filter host-skeleton. It's needed becauses the host-dependencies are derived from the dependencies of the target package where 'host-' is preprended to the depedency name. In the pkg-generic we add skeleton as a dependency to every package. The whole system/system.mk is now removed at the profit of package/skeleton/skeleton.mk [Thomas: - rebase on top of master and fix some minor conflicts - remove the 'select BR2_PACKAGE_SKELETON' in BR2_ROOTFS_SKELETON_DEFAULT and BR2_ROOTFS_SKELETON_CUSTOM, since anyway the skeleton package is always enabled. - fixup a few mistakes in the getty handling due to misnamed variables.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-virtual.mk')
-rw-r--r--package/pkg-virtual.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-virtual.mk b/package/pkg-virtual.mk
index 2889ef9be..9c68b511c 100644
--- a/package/pkg-virtual.mk
+++ b/package/pkg-virtual.mk
@@ -50,7 +50,7 @@ $(2)_VERSION = virtual
# This must be repeated from inner-generic-package, otherwise we get an empty
# _DEPENDENCIES
ifeq ($(4),host)
-$(2)_DEPENDENCIES ?= $$(filter-out host-toolchain $(1),\
+$(2)_DEPENDENCIES ?= $$(filter-out host-skeleton host-toolchain $(1),\
$$(patsubst host-host-%,host-%,$$(addprefix host-,$$($(3)_DEPENDENCIES))))
endif