summaryrefslogtreecommitdiff
path: root/package/portmap
diff options
context:
space:
mode:
authorANDY KENNEDY <ANDY.KENNEDY@adtran.com>2014-09-08 21:43:45 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-09-21 22:07:02 +0200
commit48713e430d5e86d4996af27752e48bea7859c45f (patch)
treeb9e40c207fac34e39a33e16f8156a4a26787a34e /package/portmap
parent39fadc2863d477433df4cad983c7c7216babdcd7 (diff)
portmap: fix static linking
Portmap builds and links, however, does not get built correctly when BR2_PREFER_STATIC_LIB is selected. There are no dynamic libraries in rootfs.tar, however, portmap gets linked dynamically without regards to the PREFER_STATIC_LIB tags. LDFLAGS was not being passed into the build of portmap. Signed-off-by: Andy Kennedy <andy.kennedy@adtran.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/portmap')
-rw-r--r--package/portmap/portmap.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/portmap/portmap.mk b/package/portmap/portmap.mk
index 82035553e..01895976a 100644
--- a/package/portmap/portmap.mk
+++ b/package/portmap/portmap.mk
@@ -17,8 +17,7 @@ PORTMAP_FLAGS += NO_FORK=1
endif
define PORTMAP_BUILD_CMDS
- CFLAGS="$(TARGET_CFLAGS)" \
- $(MAKE) CC="$(TARGET_CC)" -C $(@D) $(PORTMAP_FLAGS)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(PORTMAP_FLAGS)
endef
define PORTMAP_INSTALL_TARGET_CMDS