summaryrefslogtreecommitdiff
path: root/package/portmap
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-30 15:17:57 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-01 22:44:35 +0100
commitf763f74422024780d23c0f0ffb2aa71b9b4a2e25 (patch)
treecc111efc39f4ad87ff8889af2d2b1c394577e28f /package/portmap
parent8c418f1bc40e0e5af9cb1d11071b9178f0360e34 (diff)
portmap: improve installation of binaries
This commit explicits the permissions with which executables are installed, and also makes sure that the build is aborted if one of the binaries cannot be installed, instead of silently ignoring the error. [Peter: fixop typos in commit message as noted by Yann] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/portmap')
-rw-r--r--package/portmap/portmap.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/portmap/portmap.mk b/package/portmap/portmap.mk
index a41044318..5caf54cb2 100644
--- a/package/portmap/portmap.mk
+++ b/package/portmap/portmap.mk
@@ -22,7 +22,7 @@ endef
define PORTMAP_INSTALL_TARGET_CMDS
for sbin in $(PORTMAP_SBINS); do \
- $(INSTALL) -D $(@D)/$$sbin $(TARGET_DIR)/sbin/$$sbin; \
+ $(INSTALL) -D -m 0755 $(@D)/$$sbin $(TARGET_DIR)/sbin/$$sbin || exit 1; \
done
endef