summaryrefslogtreecommitdiff
path: root/package/prboom
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-12-14 00:14:40 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-14 00:14:40 +0100
commitf80033bbe7106c9e7447a52bbf83638ac12b8d69 (patch)
treea1807c4a858fc45ee7648671b4024cf921718a8c /package/prboom
parent768a0eb7910acc502cb3f0e6329a708cda899af6 (diff)
prboom: fix static linking
Fixes: http://autobuild.buildroot.net/results/97b/97bb50add010e44aca8fcb079d8df9270d3cae45/ http://autobuild.buildroot.net/results/a96/a969fd15a652df96c2414cf0c5f2e345d38e6e6c/ http://autobuild.buildroot.net/results/9ba/9ba92c01b2c6b6eae2dcda60c2b80d66d2002d4b/ http://autobuild.buildroot.net/results/776/776394ba89070ee2fa6e81585078df0a0e2ae3f2/ And many more. SDL_mixer uses symbols from SDL, but ends up after it on the link cmdline, breaking static linking. Fix it by forcing the SDL libs at the very end. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/prboom')
-rw-r--r--package/prboom/prboom.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/prboom/prboom.mk b/package/prboom/prboom.mk
index c39b5a34a..7f9d6a0ba 100644
--- a/package/prboom/prboom.mk
+++ b/package/prboom/prboom.mk
@@ -15,6 +15,12 @@ ifeq ($(BR2_PACKAGE_LIBPNG),y)
PRBOOM_DEPENDENCIES += libpng
endif
+ifeq ($(BR2_STATIC_LIBS),y)
+# SDL_mixer uses symbols from SDL, but ends up after it on the link
+# cmdline. Fix it by forcing the SDL libs at the very end
+PRBOOM_CONF_ENV += LIBS="$(shell $(STAGING_DIR)/usr/bin/sdl-config --static-libs)"
+endif
+
PRBOOM_CONF_OPTS = \
--oldincludedir=$(STAGING_DIR)/usr/include \
--with-sdl-prefix=$(STAGING_DIR)/usr \