summaryrefslogtreecommitdiff
path: root/package/pugixml
diff options
context:
space:
mode:
authorTheo Debrouwere <t.debrouwere@televic.com>2016-09-07 17:37:07 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-09-07 21:36:16 +0200
commit27071be0d8c648a6f7ec314c29f5b3a033e1208a (patch)
tree7f3b409ea70386339f75f668abd7d1e2637bbf46 /package/pugixml
parent75f217f253837c01360f61c6c3535011ab2891b5 (diff)
pugixml: new package
pugixml is a light-weight C++ XML processing library. It features: * DOM-like interface with rich traversal/modification capabilities * Extremely fast non-validating XML parser which constructs the DOM tree from an XML file/buffer * XPath 1.0 implementation for complex data-driven tree queries * Full Unicode support with Unicode interface variants and automatic encoding conversions Homepage: http://pugixml.org/ Repository: https://github.com/zeux/pugixml Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pugixml')
-rw-r--r--package/pugixml/Config.in16
-rw-r--r--package/pugixml/pugixml.hash2
-rw-r--r--package/pugixml/pugixml.mk15
3 files changed, 33 insertions, 0 deletions
diff --git a/package/pugixml/Config.in b/package/pugixml/Config.in
new file mode 100644
index 000000000..5310b10cb
--- /dev/null
+++ b/package/pugixml/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_PUGIXML
+ bool "pugixml"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Light-weight, simple and fast XML parser for C++ with XPath support
+
+ Features:
+ * DOM-like interface with rich traversal/modification capabilities
+ * Extremely fast non-validating XML parser which constructs the DOM tree
+ from an XML file/buffer
+ * XPath 1.0 implementation for complex data-driven tree queries
+ * Full Unicode support with Unicode interface variants and automatic
+ encoding conversions
+
+ http://pugixml.org/
+ https://github.com/zeux/pugixml
diff --git a/package/pugixml/pugixml.hash b/package/pugixml/pugixml.hash
new file mode 100644
index 000000000..9007f7cae
--- /dev/null
+++ b/package/pugixml/pugixml.hash
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca pugixml-1.7.tar.gz
diff --git a/package/pugixml/pugixml.mk b/package/pugixml/pugixml.mk
new file mode 100644
index 000000000..2e4f0ce56
--- /dev/null
+++ b/package/pugixml/pugixml.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# pugixml
+#
+################################################################################
+
+PUGIXML_VERSION = 1.7
+PUGIXML_SITE = http://github.com/zeux/pugixml/releases/download/v$(PUGIXML_VERSION)
+PUGIXML_LICENSE = MIT
+PUGIXML_LICENSE_FILES = readme.txt
+PUGIXML_INSTALL_STAGING = YES
+
+PUGIXML_SUBDIR = scripts
+
+$(eval $(cmake-package))