summaryrefslogtreecommitdiff
path: root/package/pugixml
diff options
context:
space:
mode:
authorTheo Debrouwere <theo.debrouwere@skynet.be>2016-09-12 10:14:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-12 11:18:41 +0200
commitd28aa481b3cea9cca4c7d259618235d63f62fd59 (patch)
tree6e51a3916c24eafc218d2fd32890c35105ec5f8b /package/pugixml
parentf6ab3e1e99aa0e8ff5fd4dcc7d12958c7aa25c2c (diff)
package/pugixml: Fix CMakelists.txt cxx_long_long_type bug.
CMakelist.txt tries to enable the cxx_long_long_type option, even if the feature isn't available. (Which causes some builds to fail) The included patch checks if the option is present before applying it. The patch was backported from: https://github.com/zeux/pugixml/commit/4dbb5646196a4a3cc94097f1473ef11d1d44df11 Signed-off-by: Theo Debrouwere <t.debrouwere@televic.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pugixml')
-rw-r--r--package/pugixml/0001-check-cxx_long_long_type-existence.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/pugixml/0001-check-cxx_long_long_type-existence.patch b/package/pugixml/0001-check-cxx_long_long_type-existence.patch
new file mode 100644
index 000000000..a53c84a29
--- /dev/null
+++ b/package/pugixml/0001-check-cxx_long_long_type-existence.patch
@@ -0,0 +1,33 @@
+From 6cfd9c14ced26c8220f7f7ea99610cbdbfb9eba7 Mon Sep 17 00:00:00 2001
+From: Theo Debrouwere <theo.debrouwere@skynet.be>
+Date: Mon, 12 Sep 2016 09:38:56 +0200
+Subject: [PATCH] Bugfix: check if cxx_long_long_type is present before
+ applying it.
+
+Check if cxx_long_long_type is present in the list of compiler features
+before adding it as a target_compile_feature.
+
+Patch was backported from
+https://github.com/zeux/pugixml/commit/4dbb5646196a4a3cc94097f1473ef11d1d44df11
+
+Signed-off-by: Theo Debrouwere <theo.debrouwere@skynet.be>
+---
+ scripts/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
+index 40a7ab0..6403753 100644
+--- a/scripts/CMakeLists.txt
++++ b/scripts/CMakeLists.txt
+@@ -26,7 +26,7 @@ else()
+ endif()
+
+ # Enable C++11 long long for compilers that are capable of it
+-if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1)
++if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1 AND ";${CMAKE_CXX_COMPILE_FEATURES};" MATCHES ";cxx_long_long_type;")
+ target_compile_features(pugixml PUBLIC cxx_long_long_type)
+ endif()
+
+--
+2.9.3
+