summaryrefslogtreecommitdiff
path: root/package/pulseaudio
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-10-26 03:03:20 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-10-26 03:03:20 +0100
commit7006bff9b3cda17b36bd45e94426b64f270c625e (patch)
tree6fe2c0bea18af4b9413cd0b9e6490fe63bd2c1c1 /package/pulseaudio
parent1359943effe4051f048597f503c499f8f34dd362 (diff)
pulseaudio: correct libgtk3 handling
The gtk3 support uses X11 specific functionality, so it should only be enabled if the X11 backend is enabled. Fixes: http://autobuild.buildroot.net/results/9d9/9d9ddea26a5193367a80eede1be1122cec5cd939/ http://autobuild.buildroot.net/results/3fb/3fbbdbf39e29319b349b2cf155397a121f24bf28/ http://autobuild.buildroot.net/results/ccf/ccf31740a0e730f2626db9051931b1e0703c770d/ And many others. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pulseaudio')
-rw-r--r--package/pulseaudio/pulseaudio.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pulseaudio/pulseaudio.mk b/package/pulseaudio/pulseaudio.mk
index 8d3d0f765..d24dcc8f2 100644
--- a/package/pulseaudio/pulseaudio.mk
+++ b/package/pulseaudio/pulseaudio.mk
@@ -47,6 +47,14 @@ else
PULSEAUDIO_CONF_OPTS += --without-caps
endif
+# gtk3 support needs X11 backend
+ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
+PULSEAUDIO_DEPENDENCIES += libgtk3
+PULSEAUDIO_CONF_OPTS += --enable-gtk3
+else
+PULSEAUDIO_CONF_OPTS += --disable-gtk3
+endif
+
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
# The optional webrtc echo canceller is written in C++, causing auto* to want
# to link module-echo-cancel.so with CXX even if webrtc ISN'T used.