summaryrefslogtreecommitdiff
path: root/package/pure-ftpd
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-09-28 21:12:50 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-02 21:43:36 +0200
commit212820b65fd02bc1ef13498a9becdbd8e59eb35a (patch)
tree839fb50e9988bb6df706bb4195322ff135fb09f2 /package/pure-ftpd
parentc234259969e354f465b7dc8e58d4fdb3799c2862 (diff)
package/pure-ftpd: New package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pure-ftpd')
-rw-r--r--package/pure-ftpd/Config.in12
-rw-r--r--package/pure-ftpd/pure-ftpd-0001-cross.patch25
-rw-r--r--package/pure-ftpd/pure-ftpd.mk35
3 files changed, 72 insertions, 0 deletions
diff --git a/package/pure-ftpd/Config.in b/package/pure-ftpd/Config.in
new file mode 100644
index 000000000..c1b2529db
--- /dev/null
+++ b/package/pure-ftpd/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PURE_FTPD
+ bool "pure-ftpd"
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+ depends on BR2_USE_MMU # fork()
+ help
+ Pure-FTPd is a free (BSD), secure, production-quality and standard-
+ conformant FTP server. It doesn't provide useless bells and whistles,
+ but focuses on efficiency and ease of use. It provides simple answers
+ to common needs, plus unique useful features for personal users as
+ well as hosting providers.
+
+ http://www.pureftpd.org
diff --git a/package/pure-ftpd/pure-ftpd-0001-cross.patch b/package/pure-ftpd/pure-ftpd-0001-cross.patch
new file mode 100644
index 000000000..f8b1d81da
--- /dev/null
+++ b/package/pure-ftpd/pure-ftpd-0001-cross.patch
@@ -0,0 +1,25 @@
+Do not include host paths when cross-compiling.
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr pure-ftpd-1.0.36.org/configure pure-ftpd-1.0.36/configure
+--- pure-ftpd-1.0.36.org/configure 2012-03-16 06:29:23.000000000 +0100
++++ pure-ftpd-1.0.36/configure 2014-09-28 19:55:56.650529713 +0200
+@@ -6319,17 +6319,6 @@
+
+
+
+-if test -d /usr/local/include; then
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-fi
+-
+-if test -d /usr/kerberos/include; then
+- CPPFLAGS="$CPPFLAGS -I/usr/kerberos/include"
+-fi
+-
+-if test -d /usr/local/lib; then
+- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-fi
+
+ if uname | fgrep SunOS > /dev/null 2> /dev/null ; then
+ CPPFLAGS="$CPPFLAGS -D_XPG4_2=1"
diff --git a/package/pure-ftpd/pure-ftpd.mk b/package/pure-ftpd/pure-ftpd.mk
new file mode 100644
index 000000000..cf43220cb
--- /dev/null
+++ b/package/pure-ftpd/pure-ftpd.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# pure-ftpd
+#
+################################################################################
+
+PURE_FTPD_VERSION = 1.0.36
+PURE_FTPD_SITE = http://download.pureftpd.org/pub/pure-ftpd/releases
+PURE_FTPD_LICENSE = ISC
+PURE_FTPD_LICENSE_FILES = COPYING
+PURE_FTPD_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+PURE_FTPD_CONF_OPT = \
+ --with-altlog \
+ --with-puredb \
+ --with-rfc2640
+
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+PURE_FTPD_CONF_OPT += --with-capabilities
+PURE_FTPD_DEPENDENCIES += libcap
+else
+PURE_FTPD_CONF_OPT += --without-capabilities
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+PURE_FTPD_CONF_OPT += --with-tls
+PURE_FTPD_DEPENDENCIES += openssl
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+PURE_FTPD_CONF_ENV += LIBS='-lssl -lcrypto -lz'
+endif
+else
+PURE_FTPD_CONF_OPT += --without-tls
+endif
+
+$(eval $(autotools-package))