summaryrefslogtreecommitdiff
path: root/package/pure-ftpd
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 10:50:07 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:41:06 +0100
commit34c58907f69e425cd9d391bb28b83165a80b7d39 (patch)
tree0b0444ff15fc227004ba24477a2ab0263a644572 /package/pure-ftpd
parent5280efe34f198bf0a5580bb976ba24ca9669cca4 (diff)
package/pure-ftpd: add optional support for elfutils
When elfutils was compiled before, pure-ftpd will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/sbin/pure-ftpd | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [libelf.so.1] 0x0000000000000001 (NEEDED) Shared library: [libcrypt.so.1] 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] The build system offers no option to en-/disable elfutils support, check m4/getloadavg.m4, line 44. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pure-ftpd')
-rw-r--r--package/pure-ftpd/pure-ftpd.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pure-ftpd/pure-ftpd.mk b/package/pure-ftpd/pure-ftpd.mk
index aa65e9eea..8df4c232c 100644
--- a/package/pure-ftpd/pure-ftpd.mk
+++ b/package/pure-ftpd/pure-ftpd.mk
@@ -16,6 +16,10 @@ PURE_FTPD_CONF_OPTS = \
--with-puredb \
--with-rfc2640
+ifeq ($(BR2_PACKAGE_ELFUTILS),y)
+PURE_FTPD_DEPENDENCIES += elfutils
+endif
+
ifeq ($(BR2_PACKAGE_LIBCAP),y)
PURE_FTPD_CONF_OPTS += --with-capabilities
PURE_FTPD_DEPENDENCIES += libcap