summaryrefslogtreecommitdiff
path: root/package/python-cffi
diff options
context:
space:
mode:
authorOli Vogt <oli.vogt.pub01@gmail.com>2014-05-20 13:53:00 +1200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 21:31:32 +0200
commite5bf154592691b104e2ee0f97f9fcaf8cce54a52 (patch)
treeae87ccc422f5cfb75ab71b03b8d178c7472faa7f /package/python-cffi
parent8793ddcd6f87b50934a4b4d1a53b7bf54cf650cb (diff)
python: new module cffi
Foreign Function Interface for Python calling C code. [Thomas: add dependency on host-pkgconf and libffi, enable on Python 3 since the module builds fine and loads fine with Python 3 as well.] Signed-off-by: oli vogt <oli.vogt.pub01@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-cffi')
-rw-r--r--package/python-cffi/Config.in10
-rw-r--r--package/python-cffi/python-cffi.mk15
2 files changed, 25 insertions, 0 deletions
diff --git a/package/python-cffi/Config.in b/package/python-cffi/Config.in
new file mode 100644
index 000000000..f18ed96f6
--- /dev/null
+++ b/package/python-cffi/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_CFFI
+ bool "python-cffi"
+ depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+ select BR2_PACKAGE_LIBFFI
+ help
+ This is the Foreign Function Interface for Python calling C
+ code. The aim of this project is to provide a convenient
+ and reliable way of calling C code from Python.
+
+ https://pypi.python.org/pypi/cffi
diff --git a/package/python-cffi/python-cffi.mk b/package/python-cffi/python-cffi.mk
new file mode 100644
index 000000000..8499a7bbb
--- /dev/null
+++ b/package/python-cffi/python-cffi.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-cffi
+#
+################################################################################
+
+PYTHON_CFFI_VERSION = 0.8.2
+PYTHON_CFFI_SOURCE = cffi-$(PYTHON_CFFI_VERSION).tar.gz
+PYTHON_CFFI_SITE = https://pypi.python.org/packages/source/c/cffi/
+PYTHON_CFFI_SETUP_TYPE = setuptools
+PYTHON_CFFI_DEPENDENCIES = host-pkgconf libffi
+PYTHON_CFFI_LICENSE = MIT
+PYTHON_CFFI_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))