summaryrefslogtreecommitdiff
path: root/package/python-cherrypy
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2015-02-08 10:59:19 -0500
committerPeter Korsgaard <peter@korsgaard.com>2015-02-23 23:14:05 +0100
commit1f81429f825e8ab1c4d739638d2b913f98e78612 (patch)
tree7484a32cfe36634aee115b3c6768c46175c2f87a /package/python-cherrypy
parentcd3c6e26c5c368ee76ab2a42c1c76994f93a4c9f (diff)
python-cherrypy: new package
Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python-cherrypy')
-rw-r--r--package/python-cherrypy/Config.in10
-rw-r--r--package/python-cherrypy/python-cherrypy.hash3
-rw-r--r--package/python-cherrypy/python-cherrypy.mk14
3 files changed, 27 insertions, 0 deletions
diff --git a/package/python-cherrypy/Config.in b/package/python-cherrypy/Config.in
new file mode 100644
index 000000000..6e32ec2a1
--- /dev/null
+++ b/package/python-cherrypy/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_CHERRYPY
+ bool "python-cherrypy"
+ select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON # runtime
+ select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3 # runtime
+ select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
+ select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+ help
+ A minimalist web framework
+
+ http://www.cherrypy.org
diff --git a/package/python-cherrypy/python-cherrypy.hash b/package/python-cherrypy/python-cherrypy.hash
new file mode 100644
index 000000000..08fa0754b
--- /dev/null
+++ b/package/python-cherrypy/python-cherrypy.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=9772dbee426d656f01a13881e2b139d8, sha256 locally computed
+md5 9772dbee426d656f01a13881e2b139d8 CherryPy-3.6.0.tar.gz
+sha256 a149271819a15417104aa8f641ad5b96287070f0153e6ef2832a87e2c693d75d CherryPy-3.6.0.tar.gz
diff --git a/package/python-cherrypy/python-cherrypy.mk b/package/python-cherrypy/python-cherrypy.mk
new file mode 100644
index 000000000..a08b21ab5
--- /dev/null
+++ b/package/python-cherrypy/python-cherrypy.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-cherrypy
+#
+################################################################################
+
+PYTHON_CHERRYPY_VERSION = 3.6.0
+PYTHON_CHERRYPY_SOURCE = CherryPy-$(PYTHON_CHERRYPY_VERSION).tar.gz
+PYTHON_CHERRYPY_SITE = http://pypi.python.org/packages/source/C/CherryPy
+PYTHON_CHERRYPY_LICENSE = BSD-3c
+PYTHON_CHERRYPY_LICENSE_FILES = LICENSE.txt
+PYTHON_CHERRYPY_SETUP_TYPE = distutils
+
+$(eval $(python-package))