summaryrefslogtreecommitdiff
path: root/package/python-dicttoxml
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-07-22 08:36:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-23 14:57:17 +0200
commit6e386a04d6a7120b35bdb8f64c82f009ba2332fe (patch)
treecec1e65ccee5f7638e33472cbc44d9867bc894d8 /package/python-dicttoxml
parentf4f37eb633b7a12f418bb791f870d1d260c4efa1 (diff)
python-dicttoxml: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-dicttoxml')
-rw-r--r--package/python-dicttoxml/Config.in9
-rw-r--r--package/python-dicttoxml/python-dicttoxml.hash3
-rw-r--r--package/python-dicttoxml/python-dicttoxml.mk14
3 files changed, 26 insertions, 0 deletions
diff --git a/package/python-dicttoxml/Config.in b/package/python-dicttoxml/Config.in
new file mode 100644
index 000000000..152afbb6b
--- /dev/null
+++ b/package/python-dicttoxml/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_DICTTOXML
+ bool "python-dicttoxml"
+ select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
+ help
+ Converts a Python dictionary or other native data type into a valid
+ XML string.
+
+ https://github.com/quandyfactory/dicttoxml
diff --git a/package/python-dicttoxml/python-dicttoxml.hash b/package/python-dicttoxml/python-dicttoxml.hash
new file mode 100644
index 000000000..32ba6b0fd
--- /dev/null
+++ b/package/python-dicttoxml/python-dicttoxml.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/dicttoxml/json, sha256 locally computed
+md5 ec5643a048cf32dad3c28db236b923e4 dicttoxml-1.7.4.tar.gz
+sha256 ea44cc4ec6c0f85098c57a431a1ee891b3549347b07b7414c8a24611ecf37e45 dicttoxml-1.7.4.tar.gz
diff --git a/package/python-dicttoxml/python-dicttoxml.mk b/package/python-dicttoxml/python-dicttoxml.mk
new file mode 100644
index 000000000..697671500
--- /dev/null
+++ b/package/python-dicttoxml/python-dicttoxml.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-dicttoxml
+#
+################################################################################
+
+PYTHON_DICTTOXML_VERSION = 1.7.4
+PYTHON_DICTTOXML_SOURCE = dicttoxml-$(PYTHON_DICTTOXML_VERSION).tar.gz
+PYTHON_DICTTOXML_SITE = https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9
+PYTHON_DICTTOXML_SETUP_TYPE = distutils
+PYTHON_DICTTOXML_LICENSE = GPLv2
+PYTHON_DICTTOXML_LICENSE_FILES = LICENCE.txt
+
+$(eval $(python-package))