summaryrefslogtreecommitdiff
path: root/package/python-engineio
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-07-01 12:06:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-01 15:04:39 +0200
commita6a675c0ea6a82438f1349222a2e2e390729a66e (patch)
tree32b243363b29c116f5f221a5b6fd02635a70b903 /package/python-engineio
parente1452c5d4f32d6ddf58bb8aea5cf23d4d77b5462 (diff)
python-engineio: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-engineio')
-rw-r--r--package/python-engineio/Config.in9
-rw-r--r--package/python-engineio/python-engineio.hash4
-rw-r--r--package/python-engineio/python-engineio.mk14
3 files changed, 27 insertions, 0 deletions
diff --git a/package/python-engineio/Config.in b/package/python-engineio/Config.in
new file mode 100644
index 000000000..b12db922a
--- /dev/null
+++ b/package/python-engineio/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_ENGINEIO
+ bool "python-engineio"
+ select BR2_PACKAGE_PYTHON_SIX # runtime
+ select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3
+ help
+ Engine.IO server.
+
+ http://github.com/miguelgrinberg/python-engineio/
diff --git a/package/python-engineio/python-engineio.hash b/package/python-engineio/python-engineio.hash
new file mode 100644
index 000000000..b2c0669bc
--- /dev/null
+++ b/package/python-engineio/python-engineio.hash
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/python-engineio/json
+md5 9b0075dbbb25d7a302eba99dd9ba4af8 python-engineio-0.9.2.tar.gz
+# sha256 calculated by scanpypi
+sha256 c53282415ed9bc3cb4e7beafb2a1ce5c369af95dcf8f968061e5bc7572b60867 python-engineio-0.9.2.tar.gz
diff --git a/package/python-engineio/python-engineio.mk b/package/python-engineio/python-engineio.mk
new file mode 100644
index 000000000..700b638ad
--- /dev/null
+++ b/package/python-engineio/python-engineio.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-engineio
+#
+################################################################################
+
+PYTHON_ENGINEIO_VERSION = 0.9.2
+PYTHON_ENGINEIO_SOURCE = python-engineio-$(PYTHON_ENGINEIO_VERSION).tar.gz
+PYTHON_ENGINEIO_SITE = https://pypi.python.org/packages/c3/8f/0e066fc7a7029893b96b1d68a0cd5e75f6410f154fa4079b2be4991f5ae0
+PYTHON_ENGINEIO_SETUP_TYPE = setuptools
+PYTHON_ENGINEIO_LICENSE = MIT
+PYTHON_ENGINEIO_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))