summaryrefslogtreecommitdiff
path: root/package/python-humanize
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-07-06 09:18:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-06 23:00:57 +0200
commitfb131be88aef08263543cf07fbef028558b8fac6 (patch)
treeebb5d436bec6cfd5b80763573eb33e20781d57f6 /package/python-humanize
parent1ba26756d838736c2fe4936a3a25f4c8762133ba (diff)
python-humanize: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-humanize')
-rw-r--r--package/python-humanize/Config.in9
-rw-r--r--package/python-humanize/python-humanize.hash3
-rw-r--r--package/python-humanize/python-humanize.mk14
3 files changed, 26 insertions, 0 deletions
diff --git a/package/python-humanize/Config.in b/package/python-humanize/Config.in
new file mode 100644
index 000000000..f4f4e67b6
--- /dev/null
+++ b/package/python-humanize/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_HUMANIZE
+ bool "python-humanize"
+ help
+ Python humanize package contains various common humanization
+ utilities, like turning a number into a fuzzy human readable
+ duration ('3 minutes ago') or into a human readable size or
+ throughput.
+
+ http://github.com/jmoiron/humanize
diff --git a/package/python-humanize/python-humanize.hash b/package/python-humanize/python-humanize.hash
new file mode 100644
index 000000000..bb66e4446
--- /dev/null
+++ b/package/python-humanize/python-humanize.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/humanize/json, sha256 locally computed
+md5 e8473d9dc1b220911cac2edd53b1d973 humanize-0.5.1.tar.gz
+sha256 a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19 humanize-0.5.1.tar.gz
diff --git a/package/python-humanize/python-humanize.mk b/package/python-humanize/python-humanize.mk
new file mode 100644
index 000000000..60ec82bd4
--- /dev/null
+++ b/package/python-humanize/python-humanize.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-humanize
+#
+################################################################################
+
+PYTHON_HUMANIZE_VERSION = 0.5.1
+PYTHON_HUMANIZE_SOURCE = humanize-$(PYTHON_HUMANIZE_VERSION).tar.gz
+PYTHON_HUMANIZE_SITE = https://pypi.python.org/packages/8c/e0/e512e4ac6d091fc990bbe13f9e0378f34cf6eecd1c6c268c9e598dcf5bb9
+PYTHON_HUMANIZE_SETUP_TYPE = setuptools
+PYTHON_HUMANIZE_LICENSE = MIT
+PYTHON_HUMANIZE_LICENSE_FILES = LICENCE
+
+$(eval $(python-package))