summaryrefslogtreecommitdiff
path: root/package/python-idna
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2015-12-14 09:24:50 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-15 22:41:26 +0100
commitdd3afecc70c8b727af4a8d58e11ba2c67ff2ebd9 (patch)
treed90ba1de2499fbcf8f09076ef151c4d01bdc257f /package/python-idna
parent50466d01045c857f1905bd4a78469b3d7923a4d5 (diff)
python-idna: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-idna')
-rw-r--r--package/python-idna/Config.in10
-rw-r--r--package/python-idna/python-idna.hash3
-rw-r--r--package/python-idna/python-idna.mk14
3 files changed, 27 insertions, 0 deletions
diff --git a/package/python-idna/Config.in b/package/python-idna/Config.in
new file mode 100644
index 000000000..4ff4581d5
--- /dev/null
+++ b/package/python-idna/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_IDNA
+ bool "python-idna"
+ help
+ A library to support the Internationalised Domain Names in
+ Applications (IDNA) protocol as specified in RFC 5891. This
+ version of the protocol is often referred to as “IDNA2008”
+ and can produce different results from the earlier standard
+ from 2003.
+
+ https://github.com/kjd/idna
diff --git a/package/python-idna/python-idna.hash b/package/python-idna/python-idna.hash
new file mode 100644
index 000000000..10e3e9d84
--- /dev/null
+++ b/package/python-idna/python-idna.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=bd17a9d15e755375f48a62c13b25b801, sha256 locally computed
+md5 bd17a9d15e755375f48a62c13b25b801 idna-2.0.tar.gz
+sha256 16199aad938b290f5be1057c0e1efc6546229391c23cea61ca940c115f7d3d3b idna-2.0.tar.gz
diff --git a/package/python-idna/python-idna.mk b/package/python-idna/python-idna.mk
new file mode 100644
index 000000000..7dd1253c1
--- /dev/null
+++ b/package/python-idna/python-idna.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-idna
+#
+################################################################################
+
+PYTHON_IDNA_VERSION = 2.0
+PYTHON_IDNA_SOURCE = idna-$(PYTHON_IDNA_VERSION).tar.gz
+PYTHON_IDNA_SITE = https://pypi.python.org/packages/source/i/idna
+PYTHON_IDNA_LICENSE = BSD-3c
+PYTHON_IDNA_LICENSE_FILES = LICENSE.rst
+PYTHON_IDNA_SETUP_TYPE = setuptools
+
+$(eval $(python-package))