summaryrefslogtreecommitdiff
path: root/package/python-ipython
diff options
context:
space:
mode:
authorPhilippe Proulx <eeppeliteloop@gmail.com>2014-07-24 15:08:49 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-27 15:37:27 +0200
commit2671e7eee324217a326c12e39c90b13573acbb74 (patch)
treeb494dd0b839e855d5eb79a8b0ed5512965e059ee /package/python-ipython
parent1030ea5a5b327b2235766f70f5d86ff2d8e63818 (diff)
python-ipython: new package
Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-ipython')
-rw-r--r--package/python-ipython/Config.in10
-rw-r--r--package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch15
-rw-r--r--package/python-ipython/python-ipython.mk14
3 files changed, 39 insertions, 0 deletions
diff --git a/package/python-ipython/Config.in b/package/python-ipython/Config.in
new file mode 100644
index 000000000..064f0c947
--- /dev/null
+++ b/package/python-ipython/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_IPYTHON
+ bool "python-ipython"
+ depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+ help
+ IPython is a command shell for interactive computing in multiple
+ programming languages, originally developed for the Python
+ programming language, that offers enhanced introspection, rich
+ media, additional shell syntax, tab completion, and rich history.
+
+ http://ipython.org/
diff --git a/package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch b/package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch
new file mode 100644
index 000000000..0fbd5a1c8
--- /dev/null
+++ b/package/python-ipython/python-ipython-001-set-correct-python-executable-path.patch
@@ -0,0 +1,15 @@
+Set correct Python executable path
+
+Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
+
+--- python-ipython-2.1.0/setupbase.py 2014-05-21 15:19:12.000000000 -0400
++++ python-ipython-2.1.0-new/setupbase.py 2014-07-23 23:34:32.892030423 -0400
+@@ -394,7 +394,7 @@ class build_scripts_entrypt(build_script
+
+ mod, func = entrypt.split(':')
+ with open(outfile, 'w') as f:
+- f.write(script_src.format(executable=sys.executable,
++ f.write(script_src.format(executable='/usr/bin/env python',
+ mod=mod, func=func))
+
+ return outfiles, outfiles
diff --git a/package/python-ipython/python-ipython.mk b/package/python-ipython/python-ipython.mk
new file mode 100644
index 000000000..d1daa7f41
--- /dev/null
+++ b/package/python-ipython/python-ipython.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-ipython
+#
+################################################################################
+
+PYTHON_IPYTHON_VERSION = 2.1.0
+PYTHON_IPYTHON_SOURCE = ipython-$(PYTHON_IPYTHON_VERSION).tar.gz
+PYTHON_IPYTHON_SITE = https://pypi.python.org/packages/source/i/ipython/
+PYTHON_IPYTHON_LICENSE = BSD-3c
+PYTHON_IPYTHON_LICENSE_FILES = COPYING.rst
+PYTHON_IPYTHON_SETUP_TYPE = distutils
+
+$(eval $(python-package))