summaryrefslogtreecommitdiff
path: root/package/python-pycrypto
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-12-23 18:39:48 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-25 10:08:45 +0100
commit441579d61391f2f395b9fc5928354f0a4418d4d4 (patch)
tree62156ce99409d97a7b75ef0eb65dccc0d62aadc8 /package/python-pycrypto
parent0a353bf26b2fd1bb0023f5605fc8cf3c130b23e0 (diff)
package/python-pycrypto: fix legal-info
The pycrypto package contains a LICENSE.orig file, but apply-patches.sh removes all .orig file, so we can't list a .orig file asa license file, as it would have disapeared by the time 'make legal-info' sould be called. Add a post-extract hook that renames this license file, so it is renamed just before we apply patches and remove .orig files. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Ryan Barnett <rjbarnet@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-pycrypto')
-rw-r--r--package/python-pycrypto/python-pycrypto.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/python-pycrypto/python-pycrypto.mk b/package/python-pycrypto/python-pycrypto.mk
index eda48bd50..f872ccc24 100644
--- a/package/python-pycrypto/python-pycrypto.mk
+++ b/package/python-pycrypto/python-pycrypto.mk
@@ -11,7 +11,17 @@ PYTHON_PYCRYPTO_SETUP_TYPE = distutils
PYTHON_PYCRYPTO_LICENSE = Public Domain, Python 2.2 License (HMAC.py, setup.py)
PYTHON_PYCRYPTO_LICENSE_FILES = COPYRIGHT LEGAL/copy/LICENSE.libtom \
- LEGAL/copy/LICENSE.orig LEGAL/copy/LICENSE.python-2.2
+ LEGAL/copy/LICENSE.python-2.2
+
+# The pycrypto package contains a LICENSE.orig file, but our patching
+# infrastrucure removes all .orig file, so we must rename that license
+# file prior to patching, so it is still available to the legal-info
+# infrastructure
+define PYTHON_PYCRYPTO_RENAME_LICENSE
+ mv $(@D)/LEGAL/copy/LICENSE.orig $(@D)/LEGAL/copy/LICENSE.original
+endef
+PYTHON_PYCRYPTO_POST_EXTRACT_HOOKS += PYTHON_PYCRYPTO_RENAME_LICENSE
+PYTHON_PYCRYPTO_LICENSE_FILES += LEGAL/copy/LICENSE.original
PYTHON_PYCRYPTO_DEPENDENCIES = gmp