summaryrefslogtreecommitdiff
path: root/package/python-pyqt
diff options
context:
space:
mode:
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>2015-05-06 16:59:36 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-06 21:34:17 +0200
commit5c95c7f84d23b527dda6e266c57a4f469f978874 (patch)
tree7a92d944274cb6d20575c83e2d29569556d56993 /package/python-pyqt
parentc7ac95b8db400e766acdcfe9b1da1c92fed3ace5 (diff)
python-pyqt: fix opengl build failure
Fix: http://autobuild.buildroot.net/results/206/2062208c171207428c9121215971e00c52bf306a/ According to configure-ng.py, PyQt_NoOpenGLES must be added to qtdetail when QT_OPENGL_ES is set. [Thomas: add comment to explain the double negation.] Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-pyqt')
-rw-r--r--package/python-pyqt/python-pyqt.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/python-pyqt/python-pyqt.mk b/package/python-pyqt/python-pyqt.mk
index 244556770..292398db0 100644
--- a/package/python-pyqt/python-pyqt.mk
+++ b/package/python-pyqt/python-pyqt.mk
@@ -40,6 +40,12 @@ ifeq ($(BR2_PACKAGE_QT_OPENSSL),)
PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_OpenSSL
endif
+# Yes, this looks a bit weird: when OpenGL ES is available, we have to
+# disable the feature that consists in not having OpenGL ES support.
+ifeq ($(BR2_PACKAGE_QT_OPENGL_ES),y)
+PYTHON_PYQT_QTDETAIL_DISABLE_FEATURES += PyQt_NoOpenGLES
+endif
+
# PyQt_qreal_double must be disabled on a number of architectures that
# use float for qreal.
ifeq ($(BR2_PACKAGE_PYTHON_PYQT_ARCH_USES_QREAL_FLOAT),y)