summaryrefslogtreecommitdiff
path: root/package/python-requests
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-11-17 17:54:28 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-11-17 17:54:28 +0100
commitb2b538bda710f750c1e534e516964dc5795af14e (patch)
treeac7ba7e537f8d5f910d8f8a053404a30ff5f040f /package/python-requests
parenta6f0cfa51fc5b0480779885a00d67c1a36e77947 (diff)
package: add python-requests
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python-requests')
-rw-r--r--package/python-requests/Config.in7
-rw-r--r--package/python-requests/python-requests.hash3
-rw-r--r--package/python-requests/python-requests.mk14
3 files changed, 24 insertions, 0 deletions
diff --git a/package/python-requests/Config.in b/package/python-requests/Config.in
new file mode 100644
index 000000000..3367cf070
--- /dev/null
+++ b/package/python-requests/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_REQUESTS
+ bool "python-requests"
+ help
+ Requests is an Apache2 Licensed HTTP library, written in
+ Python, for human beings.
+
+ http://www.python-requests.org/
diff --git a/package/python-requests/python-requests.hash b/package/python-requests/python-requests.hash
new file mode 100644
index 000000000..d187dcd2a
--- /dev/null
+++ b/package/python-requests/python-requests.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=02214b3a179e445545de4b7a98d3dd17, sha256 locally computed
+md5 02214b3a179e445545de4b7a98d3dd17 requests-2.4.3.tar.gz
+sha256 53c68313c5c6149b1a899234c000296e60a8900682accf73d6f0c6d608afc6b1 requests-2.4.3.tar.gz
diff --git a/package/python-requests/python-requests.mk b/package/python-requests/python-requests.mk
new file mode 100644
index 000000000..5c12f1b56
--- /dev/null
+++ b/package/python-requests/python-requests.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-requests
+#
+################################################################################
+
+PYTHON_REQUESTS_VERSION = 2.4.3
+PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
+PYTHON_REQUESTS_SITE = http://pypi.python.org/packages/source/r/requests
+PYTHON_REQUESTS_SETUP_TYPE = setuptools
+PYTHON_REQUESTS_LICENSE = Apache-2.0
+PYTHON_REQUESTS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))